Menù Principale

Cerca
Login
Registrati
Link sponsorizzati
Progetto del Mese su SourceForge
Vota per winPenPack su SourceForge!

winPenPack partecipa al concorso "Progetto del Mese per Giugno 2016" su SourceForge.

Vota adesso!
<< Discussione precedente | Discussione successiva >>   
Impossibility to change the language permanently in X-KeePass-1 1.21 rev[10]

Autore Messaggio
dropper
mar 18 ott 2011 - 10:15

online
Utente registrato #39636
Registrato il: mar 15 feb 2011 - 23:47
Messaggi: 165

I've tried to change in the X-KeePass-1 1.21 rev [10] the language from English to German. To this end I started X-KeePass and went to View -> Change Language ... German and selected the language German. Then it worked flawlessly. But when I finished the program X-KeePass and I started it again, the English language was set. How can I solve this language problem?
Torna ad inizio pagina
ZioZione
mar 18 ott 2011 - 10:44
online

Utente registrato #74
Registrato il: dom 21 gen 2007 - 11:31
Provenienza: Tradate (VA)
Messaggi: 3821
Hi dropper,
I suppose that you are using the \English_users\X-KeePass-1.ini file, copied into the root folder, and also that you already downloaded the german.lng file fromm KeePass site and copying into \Bin\KeePass-1 folder (sorry for being so pedantic, is not for you, but to give a general method to all other users).
The .ini file is localized in English and uses the KeeLanguage=Standard option. For let it work in German language, you have substantially two ways, both editing X-KeePass-1.ini file:

1) (preferred) comment row 45, i.e. prefix it with a ";" character, as follows

;KeePass|KeeLanguage=Standard

2) edit row 45 as follows

KeePass|KeeLanguage=German

The option (1) is preferred (by me ) because is more general and allows also other languages users to let X-KeePass-1 to be localized in their native language.
Of course, changing the language from within KeePass, it asks to restart. DON'T RESTART, but close and rerun X-KeePass-1.exe.
Please let me know if this fixes your problem.
Best Regards
ZioZione
Torna ad inizio pagina
dropper
mar 18 ott 2011 - 11:51

online
Utente registrato #39636
Registrato il: mar 15 feb 2011 - 23:47
Messaggi: 165
Hi ZioZione,

The solution, which you have described, is applied to the case, that I downloaded X-KeePass 1_1.21_rev10.zip and then extracted it into a self-selected folder (eg the folder named "X-KeePass"). In my case I use X-KeePass about the winPenPackNet_Full menu.

Also I have downloaded from the website -Link- the current version of the file "German.lng". Then I have pasted this file "German.lng" in the folder D:\wpp_full_4.0-beta2\winPenPack\Bin\KeePass-1 (overwriting the existing file "German.lng"). Therefore, I would recommend that in the official version of X-KeePass-1 1.21 rev[10] already this current file "German.lng" is included.

Then I went into the folder D:\wpp_full_4.0-beta2\winPenPack\XDrive\en and copied the file "X-KeePass-1.ini" and pasted it into the folder D:\wpp_full_4.0-beta2\winPenPack\XDrive (overwriting the existing file "X-KeePass-1.ini"). Then I edited the file "X-KeePass 1.ini" according to your proposed variant 1.

ZioZione wrote ...

1) (preferred) comment row 45, i.e. prefix it with a ";" character, as follows

;KeePass|KeeLanguage=Standard


Now I've started X-KeePass and changed the language from within X-KeePass. It asks to restart and when I do it, X-KeePass started properly in German.



[ Modificato mar 18 ott 2011 - 11:54 ]
Torna ad inizio pagina

Moderatori: Danix, Taf, Rcs, Energy, zandet2, ZioZione, Admin, LordJim60

Salta:     Torna ad inizio pagina

RSS discussione: rss 0.92 RSS discussione: rss 2.0 RSS discussione: RDF
Powered by e107 Forum System