Main menu

Search
Login
Signup
Links
<< Previous thread | Next thread >>   
X-Gimp (rev14) test richiesto

Author Post
Danix
Mon 11 May 2009 - 00:39

online

Registered Member #1
Joined: Fri 29 Dec 2006 - 05:38
Location: Sassari
Posts: 12935

Avrei bisogno di un riscontro per il nuovo X-Gimp launcher che dovrebbe velocizzare notevolmente l'avvio dell'applicazione.

Il test può essere effettuato:
  1. installando direttamente il launcher sopra il precedente (rev13), spostando in un'altra partizione (o in una diversa directory) la cartella che contiene X-Gimp ed avviando X-Gimp.exe
  2. sovrascrivendo il launcher, cancellando la cartella \User\Gimp ed avviando X-Gimp.exe
x-gimp_2.6.6_rev14.zip

[ Edited Mon 11 May 2009 - 00:40 ]
Back to top
Website
Taf
Mon 11 May 2009 - 11:38

online

Registered Member #251
Joined: Mon 22 Jan 2007 - 10:12
Location: Buttrio (UD)
Posts: 3338
Provato.... Una scheggia!

PS: io ho fatto la prova con la 2.6.3

Bravo Danix!

..ora mi scarico la 2.6.6 e faccio il test anche con quella!

[ Edited Mon 11 May 2009 - 11:40 ]
Back to top
Taf
Mon 11 May 2009 - 12:05

online

Registered Member #251
Joined: Mon 22 Jan 2007 - 10:12
Location: Buttrio (UD)
Posts: 3338
Test effettuato sulla 2.6.6:

a) TEST effettuato su HD di macchina Desktop Veloce (XP Pro SP3 con i7 920 2,67 GHz - 3Gb Ram)

Con Launcher REV13 e profilo utente assente --> operativo in 11/12 secondi

Con Launcher REV14 e profilo utente assente --> operativo in 5/6 secondi

-----EDIT1----

b) TEST effettuato su PenDrive CRUZER 16Gb (quella *GIFT*! collegata su Dektop i7 920 2,67 GHz)

Con Launcher REV13 e profilo utente assente --> operativo in 25/26 secondi

Con Launcher REV14 e profilo utente assente --> operativo in 8/9 secondi !!!

----- EDIT2-----

c) TEST effettuato su PenDrive CRUZER 16Gb (sempre quella! collegata su Notebook con Xp Pro SP3 e Core 2 T2400 1,83GHz - 3Gb ram)

Con Launcher REV13 e profilo utente assente --> operativo in 37/38 secondi

Con Launcher REV14 e profilo utente assente --> operativo in 9/10 secondi !!!


COMPLIMENTISSIMI Danix!!!!!!




[ Edited Mon 11 May 2009 - 12:21 ]
Back to top
Danix
Mon 11 May 2009 - 12:13

online

Registered Member #1
Joined: Fri 29 Dec 2006 - 05:38
Location: Sassari
Posts: 12935
Bene!
Il problema stava nel file pluginrc del profilo dove ad ogni avvio veniva riscritta l'intera mappa dei plugin, percorso per percorso. Ora i percorsi vengono corretti dall'esterno e Gimp non deve quindi andare a cercare i singoli plugin per poi aggiornare i relativi percorsi nel file di configurazione, perchè li trova già.

Off topic: questo è il mio 8888 esimo messaggio



[ Edited Mon 11 May 2009 - 12:18 ]
Back to top
Website
Taf
Mon 11 May 2009 - 12:21

online

Registered Member #251
Joined: Mon 22 Jan 2007 - 10:12
Location: Buttrio (UD)
Posts: 3338
ho fatto un altro test! Leggi sopra...
Back to top
Danix
Mon 11 May 2009 - 12:24

online

Registered Member #1
Joined: Fri 29 Dec 2006 - 05:38
Location: Sassari
Posts: 12935
Sì, anche per me i tempi sono più o meno quelli.
Il problema era evidente soprattutto su pendrive nel passaggio da un drive all'altro con lettera unità diversa o su un altro computer, dove i plugin dovevano essere ricaricati ogni volta. Ora i tempi di avvio si sono ridotti a 1/4.

[ Edited Mon 11 May 2009 - 12:25 ]
Back to top
Website
ZioZione
Mon 11 May 2009 - 13:37
online

Registered Member #74
Joined: Sun 21 Jan 2007 - 11:31
Location: Tradate (VA)
Posts: 3821
Ciao Danix,
pur avendo una vecchia versione (Gimp 2.6.4, quella del pack 3.5.2), ho fatto anch'io il test richiesto.

TEST effettuato su PenDrive CRUZER 16Gb collegata su desktop con Xp Pro SP3 - Intel Pentium 4 3GHz - 2Gb ram (non ridete, è il PC su cui lavoro... )

Con Launcher REV11 e profilo utente assente --> operativo in 1'16"
Con Launcher REV14 e profilo utente assente --> operativo in 42"

Ci mette, comunque, poco più della metà del tempo: veramente notevole
Queste RE si stanno rivelando una vera manna dal cielo
Cordialmente
ZioZione
Back to top
Rcs
Mon 11 May 2009 - 14:41

online

Registered Member #675
Joined: Tue 23 Jan 2007 - 23:49
Location: Salvitelle (Sa)
Posts: 12717
Ciao ragazzi, anch'io ho testato la nuova versione del Launcher, ecco i miei risultati:

PenDrive Verbatim 4 Gb - XP Media Center Edition SP2- Intel Pentium M 1.73 - 1 Gb ram

X-Gimp 2.6.6

Launcher REV12 e profilo utente assente --> operativo in 1'12"
Launcher REV14 e profilo utente assente --> operativo in 13"

Veramente impressionante il nuovo TURBO Launcher
Back to top
NaM
Mon 11 May 2009 - 19:20

online
Registered Member #17768
Joined: Mon 16 Mar 2009 - 12:26
Location: Cesena (FC)
Posts: 9
Danix wrote ...

Avrei bisogno di un riscontro per il nuovo X-Gimp launcher che dovrebbe velocizzare notevolmente l'avvio dell'applicazione.

Provato.
Veramente impressionante la velocita' di esecuzione anche al primo start senza la cartella del profilo.
L'ho provato con un drive virtuale TrueCrypt dove al lavoro ho messo tutto il contenuto della mia chiavetta WinPenPack e la partenza rispetto a prima e' a razzo.
Complimenti Danix. Veramente un gran bel lavoro.
Grazie.
Back to top

Moderators: Danix, Taf, Rcs, Energy, zandet2, ZioZione, Admin, LordJim60

Jump:     Back to top

Syndicate this thread: rss 0.92 Syndicate this thread: rss 2.0 Syndicate this thread: RDF
Powered by e107 Forum System