Main menu

Search
Login
Signup
Links
<< Previous thread | Next thread >>   
[risolto] Problemi migrazione da X-OOo 2.x a X-OOo 3.x

Go to page       >>  
Author Post
barta
Sun 01 Feb 2009 - 21:15

online
Registered Member #4207
Joined: Tue 17 Apr 2007 - 16:50
Posts: 291

nelle precedenti versioni winPenPack di OpenOffice 2.x per il mantenimento delle opzioni utente (personalizzazione toolbars, macro, estensioni, dizionari ecc. ecc.) da una vecchia versione ad una nuova release (es. da X-OOo 2.4.1 a X-OOo 2.4.2) bastava copiare e sovrascrivere la subdirectory:

X-OpenOffice\User\OpenOffice

nella versione 3.0 la cartella ha un nome un po' diverso:

X-OpenOffice\User\OpenOffice.org 3

se uno quindi si limita a copiare ed incollare la directory X-
OpenOffice\User\ dalla 2.4.1 alla 3.0 rimane fregato perchè il nome della sub-sub-dir è diverso (OpenOffice.org 3 anziché OpenOffice e basta) e quindi le vecchie impostazioni non saranno riconosciute.

Pur copiando con il nome giusto la directory con le impostazioni, al successivo lancio di OOo ed all'apertura di un file di Writer mi si aprono i seguenti 2 messaggi di errore:

1° errore

Errore nel caricare il BASIC del documento file://C/X-OpenOffice7Bin/OpenOffice.org%203/Basis/share/basic/Launcher/script.xlb/:

Errore generale.
Errore generale di I/O.


2° errore

Errore nel caricare il BASIC del documento file://C/X-OpenOffice7Bin/OpenOffice.org%203/Basis/share/basic/Launcher/dialog.xlb/:

Errore generale.
Errore generale di I/O.


Dando OK ad entrambi Writer continua a funzionare ed apparentemente è tutto a posto.

A questo punto sono andato a vedere la subdirectory incrimintata
X-OpenOffice\Bin\OpenOffice.org 3\Basis\share\basic\Launcher

e me la sono trovata vuota: nessuna traccia dei file script.xlb e dialog.xlb

faccio inoltre notare che questa subdirectory non esiste in X-OOo 2.4.2

a questo punto ho fatto una ricerca con “trova” di Windows ed ho trovato questi files all'interno della directory X-OpenOffice\User\OpenOffice.org 3\user\basic\Standard

se copio questi file nella directory vuota di Bin i messaggi di errore non si ripresentano.
Ed effettivamente tutte le macro e le altre impostazioni risultano mantenute.

A questo punto sorge però un problema riguardante le estensioni....

come segnalato in questo topic: -Link-

mentre in X-OOo 2.x le estensioni venivano salvate in User, in X-OOo 3.0.1 vengono salvate in Bin.

Secondo me ciò genera una sorta di conflitto interno...
mi spiego meglio: se vado in Gestione Estensioni tutte le mie estensioni trasportate dalla 2.x e presenti dentro ad User appaiono installate e funzionanti ma dall'interfaccia grafica di gestione estensioni vi appare un'icona con un triangolo giallo con un punto esclamativo e un piccolo messaggio di errore che recita:

Errore: lo stato di questa estensione è sconosciuto.

Se rimuovo le estensioni e le reinstallo ex-novo queste mi vanno a finire in Bin ed i messaggi di errore da Gestione estensioni scompaiono.

Per concludere secondo me bisogna:

1- risolvere questa grana dei files script.xlb e dialog.xlb e capire come mai è necessario che siano presenti sia in Bin che User per evitare i messaggi di errore all'avvio

2- ripristinare il salvataggio delle estensioni in User (sempre che ciò non ne pregiudichi il funzionamento e non sia alla base dei messaggi di errore che leggo in gestione estensioni) in quanto renderebbe più semplice la sincronizzazione delle impostazioni tra X-OOo presenti su diversi computer (basterebbe infatti sovrascrivere la directory user)

ditemi che ne pensate.




[ Edited Tue 10 Mar 2009 - 23:16 ]
Back to top
barta
Mon 02 Feb 2009 - 10:44

online
Registered Member #4207
Joined: Tue 17 Apr 2007 - 16:50
Posts: 291
aggiungo per la cronaca che alcune difficoltà di migrazione le avevo già riscontrate nel passaggio da X-OOo 2.4.1 ad X-OOo 3.0 (vedi topic su OOo Google groups: -Link- )

della cosa ne avevo discusso anche con Taf® del winPenPack team.
Poi avevo lasciato perdere ed ero rimasto con X-OOo 2.4 in attesa della 3.0.1 che sapevo essere imminente

Attualmente i problemi riscontrati con i messaggi in avvio sono per certi versi simili ma allora quanto facevo il copia-incolla dei file mancanti poi riscontravo dei malfunzionamenti in X-OOo 3.0 relativi a certe macro (gli abcTools di questo sito : -Link- )

stavolta da X-OOo 2.4.2 a X-OOo 3.0.1 facendo il copia ed incolla queste macro non smettono di funzionare.

Spero che anche queste informazioni vi aiutino a capire dove sta il problema.
Back to top
Danix
Mon 02 Feb 2009 - 11:19

online

Registered Member #1
Joined: Fri 29 Dec 2006 - 05:38
Location: Sassari
Posts: 12938
Primo punto: compatibilità

Nelle versioni originali di OOo, il profilo viene salvato:

nel caso di OOo 2 in UserInstallation=$SYSUSERCONFIG/OpenOffice.org2
nel caso di OOo 3 in UserInstallation=$SYSUSERCONFIG/OpenOffice.org/3



Che si traducono in

C:\Documents and Settings\(user)\Dati applicazioni\OpenOffice.org2\user
C:\Documents and Settings\(user)\Dati applicazioni\OpenOffice.org\3\user


Se il Team di OpenOffice non ha pensato a garantire la compatibilità, perchè dovremmo pensarci noi?
Può essere forse che non siano completamente compatibili (vedi ad esempio problema estensioni)?


Secondo punto: estensioni
Dato per scontato che siano in Bin (e ci rimangano), bisogna capire se installando una data estensione e spostando il programma ovunque, questa non smetta di funzionare.
Hai informazioni in tal senso?


[ Edited Mon 02 Feb 2009 - 11:20 ]
Back to top
Website
barta
Mon 02 Feb 2009 - 12:02

online
Registered Member #4207
Joined: Tue 17 Apr 2007 - 16:50
Posts: 291
Grazie per la risposta.

Per prima cosa vorrei fare una premessa: in tutti i miei posts non c'è alcun tentativo di critica denigratoria al lavoro svolto dal team di winPenPack... ogni mia osservazione non è altro che user feedback al fine di dare informazioni per migliorare il prodotto.

passando ai singoli punti:

1- per quanto riguarda la compatibilità tra i profili user della 2.x e la 3.x non c'è assolutamente nessun problema.

Taf® mi ha spiegato le ragioni del diverso nome della subdir user
visto che si tratta di cambiare semplicemente il nome durante il copia incolla penso che qualunque utente sia in grado di farlo e non ritengo necessari cambiamenti da parte vostra

mi permetto però di consigliare di mettere in evidenza la questione del diverso nome delle subdir nella pagina di download di X-OOo 3.0.1 in quanto altri utenti della 2.x abituati a trasportare in toto la directory user dalla vecchia versione ed ignari di questo cambio di nome, potrebbero trovarsi nella situazione di non vedere riconosciute le vecchie impostazioni.

Della serie: “io ormai lo so come si fa, ma altri probabilmente no, quindi meglio metterli in guardia”

2- hai informazioni sul discorso dei files script.xlb e dialog.xlb ?
Personalmente non ho alcuna idea di che cosa siano e a che cosa servono... So soltanto che sono alla base dei messaggi di errore che si verificano dopo che ho trasbordato la user dir dalla 2.x alla 3.x

infatti se prendo un X-OOo 3.0.1 vergine senza trasferimento della user dir della 2.x e lo lancio i messaggi di errore non compaiono.

Ti dirò di più: in un X-OOo 3.0.1 vergine la directory incriminata ( file://C/X-OpenOffice/Bin/OpenOffice.org%203/Basis/share/basic/Launcher/ ) in cui sono contenuti i files script.xlb e dialog.xlb nemmeno esiste.

Da quanto ho capito la directory viene creata (seppure vuota) dopo che uno ha trasferito le impostazioni user della 2.x ed in seguito a ciò compaiono i messaggi di errore.

sembrerebbe quindi che la dir Launcher ed i files script.xlb e dialog.xlb non sono necessari al funzionamento di un X-OOo 3.0.1 vergine si innesca qualche cosa quando sulla 3.0.1 vengono travasate le impostazioni della 2.x.

Spero che anche queste informazioni possano esservi utili.
Io purtroppo non ho sufficienti competenze tecniche in materia


3- questione estensioni Bin vs. User

Come detto le estensioni installate con procedura canonica su X-OOo 3.0.1 (da strumenti, gestione estensioni, aggiungi) vanno a finire in una subdir di Bin e vengono correttamente visualizzate nella schermata grafica di gestione estensioni.

Dalle prove che ho fatto ciò non inficia la portabilità di X-OOo.
Ovvero, le estensioni così installate funzionano da tutte le locazioni anche se uno sposta la directory madre di X-OOo.

Come dicevo in precedenti posts e topic, personalmente preferirei che in X-OOo fossero installate e mantenute nella dir User come nella serie X-OOo 2.x. Ciò faciliterebbe la sincronizzazione e di X-OOo tra diversi computer e l'upgrade a future release in quanto tutte le customizzazioni sarebbero contenute in un'unica folder.

Vedete voi se è possibile fare ciò. Male che vada nel caso di migrazione da 2.x a 3.x toccherà disinstallare tutte le estensioni presenti in User e poi reinstallarle in Bin... ovviamente si tratta di una seccatura.

Attendo le vostre impressioni.
Back to top
Danix
Mon 02 Feb 2009 - 12:22

online

Registered Member #1
Joined: Fri 29 Dec 2006 - 05:38
Location: Sassari
Posts: 12938
Per prima cosa vorrei fare una premessa: in tutti i miei posts non c'è alcun tentativo di critica denigratoria al lavoro svolto dal team di winPenPack... ogni mia osservazione non è altro che user feedback al fine di dare informazioni per migliorare il prodotto.

Scusa, forse son stato frainteso o mi sono espresso male.
La mia domanda tradotta: siamo sicuri che il profilo di OOo_2 e OOo_3 siano completamente compatibili?
Effettivamente l'esperto di OOo è Taf, se solo si decidesse ad intervenire..
Back to top
Website
barta
Mon 02 Feb 2009 - 12:27

online
Registered Member #4207
Joined: Tue 17 Apr 2007 - 16:50
Posts: 291
Già... anch'io attendo un suo riscontro...purtroppo non l'ho visto nemmeno su Google groups dove ho aperto dei topics analoghi.

Magari voi avete la sua email e potete provare a contattarlo direttamente
Back to top
barta
Mon 02 Feb 2009 - 14:37

online
Registered Member #4207
Joined: Tue 17 Apr 2007 - 16:50
Posts: 291
Ulteriori informazioni: nel topic che ho aperto su Google groups ( -Link- ) l'esperto utente VITRIOL ha fatto alcune osservazioni che forse vi tornano utili...

ecco uno stralcio di ciò che mi ha detto

“Secondo me la questione principale è che non c'è garanzia che le
impostazioni delle versioni 2.x e 3.x siano reciprocamente compatibili.
In fase di installazione OOo 3.x, se rivela una versione 2.x già
installata, chiede se si vuole migrare le impostazioni nel nuovo
profilo. Di sicuro l'installer si occuperà di trascrivere nelle dir
giuste, e di apportare le modifiche che ritiene necessarie ai vecchi
file. Anche così, alcuni utenti hanno segnalato che non tutte le
impostazioni vengono migrate”.


Ecco ciò che gli ho risposto:

“Personalmente durante la migrazione da X-OOo 2.4.2 a X-OOo 3.0.1 non ho avuto alcun malfunzionamento né delle mie customizzazioni dell'interfaccia (posizione bottoni, toolbars, icone ecc. ecc.) nè delle macro che avevo installato e che funzionano perfettamente.

Il primo problema riscontrato è relativo ai files script.xlb e dialog.xlb ma in questo caso, almeno per quanto ho visto io, si tratta solo della rottura di avere 2 schermate di errore in avvio (una volta dato OK ad entrambe il programma funziona senza apparentemente nessun problema) poi se ad uno gli da fastidio basta ricopiare i file mancanti nei percorsi indicati nel mio post, e le schermate di errore non si ripresentano e non si hanno comunque malfunzionamenti successivi (nella migrazione da X-OOo 2.4.1 a X-OOo 3.0 invece avevo riscontrato delle noie con alcune macro, che però stavolta non sembrano risentire affatto della procedura).

Il secondo problema è quello relativo alle estensioni che ora vengono salvate in Bin anziché in User come prima, creando qualche problemuccio (messaggi di errore nella GUI di gestione estensioni) che però non pregiudica il funzionamento delle stesse.

Parlando con quelli di winPenPack a quest'ultimo proposito sembrerebbe che nell'impacchettare la serie X-OOo 3.x abbiano per qualche motivo (il webmaster Danix pensa che si sia trattato di una svista... attendo però notizie più precise dall'effettivo “assemblatore” di X-OOo.... P.S. Taf® dove ti sei cacciato?) trasferito in Bin la sede di “stoccaggio” dei file di installazione delle estensioni che invece nella serie X-OOo 2.x era presente in User.

Se questa discrepanza di directory sarà risolta. probabilmente la migrazione da X-OOo 2.4.2 a X-OOo 3.x potrebbe essere quasi indolore”.
Back to top
Danix
Mon 02 Feb 2009 - 14:57

online

Registered Member #1
Joined: Fri 29 Dec 2006 - 05:38
Location: Sassari
Posts: 12938
“Secondo me la questione principale è che non c'è garanzia che le
impostazioni delle versioni 2.x e 3.x siano reciprocamente compatibili.
In fase di installazione OOo 3.x, se rivela una versione 2.x già
installata, chiede se si vuole migrare le impostazioni nel nuovo
profilo. Di sicuro l'installer si occuperà di trascrivere nelle dir
giuste, e di apportare le modifiche che ritiene necessarie ai vecchi
file. Anche così, alcuni utenti hanno segnalato che non tutte le
impostazioni vengono migrate”.

Quanto detto conferma le mie preoccupazioni.
Quindi, la nostra scelta di separare i profili è più che azzeccata.


(il webmaster Danix pensa che si sia trattato di una svista... attendo però notizie più precise dall'effettivo “assemblatore” di X-OOo....

Ho come l'impressione che tu non abbia individuato perfettamente
i ruoli all'interno del Team..


---edit-----

Non hai pensato a chiedere a Vitriol la cosa principale: si possono spostare le estensioni nel profilo?

[ Edited Mon 02 Feb 2009 - 15:03 ]
Back to top
Website
barta
Mon 02 Feb 2009 - 15:19

online
Registered Member #4207
Joined: Tue 17 Apr 2007 - 16:50
Posts: 291


OK. la questione della separazione dei profili l'ho capita ma come ho già detto, al momento gli unici problemi riscontrati travasando la 2.x user dir (opportunamente rinominata) in X-OOo 3.0.1 sono relativi agli errori generati dai files .xlb e allo stoccaggio in Bin delle estensioni.

Dai miei tests la questione dei files .xlb la si risolve con un semplice copia-incolla (ovviamente sono possibili smentite sia da parte mia che da parte vostra) mentre l'unico problema che rimane è quello delle estensioni.

Nella prima discussione sui dizionari preinstallati vi avevo chiesto se spostare le estensioni in Bin nella X-OOo 3.0.1 (in X-OOo 2.x sono invece sempre state presenti in User) era un scelta voluto oppure un errore...

da quanto mi avete risposto è forse vera la seconda ipotesi (anche in questo caso sono possibili smentite) e quindi mi chiedo se è possibile reimpacchettare X-OOo 3.0.1 in modo da mantenerne le estensioni in user facilitando le operazioni di sincronizzazione di X-OOo.

Oltre ad usarlo come software portabile, io X-OOo lo uso anche su diversi PC fissi su cui mi alterno a lavorare (per la precisione si tratta di 4 computer) e trovavo davvero comodissimo fare di volta in volta il copia-incolla della directory user da un PC all'altro

ovviamente se le estensioni rimangono in Bin oltre ad essere costretto a disinstallarle e reinstallarle ex-novo (pazienza basta farlo una sola volta per tutte), sarei costretto a dovermi scarrozzare ogni volta (e questo lo ritengo davvero più seccante) sia la directory user che la chilometrica ed infognatissima subdir X-OpenOffice 3\Bin\OpenOffice.org 3\share\uno_packages\cache\uno_packages

secondo me il nocciolo della questione a questo punto è: si può ripristinare lo “stoccaggio” delle estensioni in User come nella 2.x anziché in Bin?

Per quanto riguarda la confusione di ruoli ti chiedo scusa...
per informazione dove la trovo una pagina dei credits con scritti i nomi e le relative mansioni degli sviluppatori di X-OOo


infine proverò a girare a Vitriol l'ultima domanda che mi fai....

una precisazione: cosa intendi esattamente per spostare nel profilo? intendi la subdir “user” o qualcos'altro

Back to top
Taf
Mon 02 Feb 2009 - 16:22

online

Registered Member #251
Joined: Mon 22 Jan 2007 - 10:12
Location: Buttrio (UD)
Posts: 3340
Scusate ma sono incasinatissimo con il lavoro....

Vi posso solo dire che io non avevo avuto questi problemi perché mi ero reso conto che le due versioni hanno la gestione estensioni non completamente compatibili (come da Voi già individuato!).
Infatti alcuni utenti hanno avuto problemi di migrazione anche passando dalla versione istallata di 2.4.1. a 3.0.

Io ho il mio OOO 3.0 utilizzato "pulito" e su di esso ho reinstallato le estensioni che utilizzo di solito.
Non avevo fatto migrazioni di dati utente.

Scusatemi di nuovo per lo scarso supporto, ma sono di frettissima... (ho delle consegne urgenti a cui sono legati dei pagamenti, quindi mi sento "dispiaciuto ma giustificato"!).

--- EDIT ---

@BARTA:

in effetti qui il "Deus ex machina" è sempre e comunque il buon Danix... io sono solo un piccolissimo granello di sabbia sul fondale di questo oceano con ottime iniziative.

Il mio unico pseudo-merito è quello di comparire su usenet per tenervi aggiornati.... attualmente non riesco proprio a fare di più.. sorry!

[ Edited Mon 02 Feb 2009 - 16:30 ]
Back to top

Go to page       >>  
Moderators: Danix, Taf, Rcs, Energy, zandet2, ZioZione, Admin, LordJim60

Jump:     Back to top

Syndicate this thread: rss 0.92 Syndicate this thread: rss 2.0 Syndicate this thread: RDF
Powered by e107 Forum System