Main menu

Search
Login
Signup
Links
<< Previous thread | Next thread >>   
X-LibO 3.4.x sul desktop crasha durante java download

Author Post
barta
Fri 11 Nov 2011 - 09:37

online
Registered Member #4207
Joined: Tue 17 Apr 2007 - 16:50
Posts: 291

cari amici di WPP,
vi segnalo quello che credo sia un bug di X-LibO.

l'ho riscontrato con X-LibO 3.4.4 scaricato ieri dal vostro sito, ma mi ricordo essermi capitato
lo stesso anche con versioni precedenti del ramo 3.4.x

il test l'ho fatto solo su un PC con Vista 64bit.

se scompatto lo zip di X-LibO sul desktop e faccio partire la procedura di inizializzazione, dopo
aver scelto la lingua di installazione (italiano) mi chiede se voglio scaricare java...

bene, dopo un po' di download di Java il programma si inchioda e mi da il messaggio che X-LibO ha
smesso di funzionare e non c'è verso di farlo funzionare.

da quel che ho capito l'inghippo si crea solo se la cartella di X-LibO sta sul desktop

se sposto il tutto in una cartella da qualsiasi altra parte invece il java download va a buon fine
Back to top
Taf
Fri 11 Nov 2011 - 11:05

online

Registered Member #251
Joined: Mon 22 Jan 2007 - 10:12
Location: Buttrio (UD)
Posts: 3338
barta wrote ...

cari amici di WPP,
vi segnalo quello che credo sia un bug di X-LibO.

SNIP

da quel che ho capito l'inghippo si crea solo se la cartella di X-LibO sta sul desktop

se sposto il tutto in una cartella da qualsiasi altra parte invece il java download va a buon fine


vedi che ci sei arrivato da solo...
il problema non è di X-LIBO, ma è creato nativamente dal sistema ospite.

il desktop in SEVEN e VISTA è un ambiente "monitorato" e quello che viene utilizzato lì viene gestito come se fosse parte del sistema ospitante e quindi un java in una sottocartella presente nel dektop non viene digerita volentieri.

Quindi, in futuro evita il desktop per fare le prove di programmi portabili
Back to top
barta
Fri 11 Nov 2011 - 11:50

online
Registered Member #4207
Joined: Tue 17 Apr 2007 - 16:50
Posts: 291
@Taf

certamente non farò più prove sul desktop...
tuttavia siccome spesso capita di salvare sul dekstop e provare subito lì i programmi portable, qualcuno potrebbe pensare che è colpa di WPP e non del proprio sistema operativo
Back to top
Taf
Fri 11 Nov 2011 - 12:10

online

Registered Member #251
Joined: Mon 22 Jan 2007 - 10:12
Location: Buttrio (UD)
Posts: 3338
infatti, se cerchi nel forum troverai altri utenti che per altre portabilixzzazioni avevano riscontrato malfunzionamenti delle portabilizzazioni testate sul Desktop.
E quando un utente chiede lumi.... noi Informiamo!

ciao!
PS: per il resto, come si comporta X-LIBO? io non ho avuto assolutamente tempo per testare questa release.

[ Edited Fri 11 Nov 2011 - 12:10 ]
Back to top
barta
Sat 12 Nov 2011 - 07:51

online
Registered Member #4207
Joined: Tue 17 Apr 2007 - 16:50
Posts: 291
@Taf

Ok, però secondo me fareste meglio a mettere un "N.B." nella pagina di download in cui si avvertono gli utenti dei possibili problemi dell'inizializzaizone su desktop in Vista e Win7...

a me è chiarissimo che la colpa non è vostra ma delle paturnie dei nuovi sistemi operativi Microsoft,
ma penso che alcuni utenti potrebbero non capire e pensare che invece è colpa di WPP.

per quanto riguarda X-LibO 3.4.4 sto incontrando alcuni problemucci nella migrazione del profilo User da X-LibO 3.3.3
faccio altri test più approfonditi e poi ti faccio sapere
Back to top
barta
Sat 12 Nov 2011 - 21:25

online
Registered Member #4207
Joined: Tue 17 Apr 2007 - 16:50
Posts: 291
@Taf
stranamente su Vista64bit non c'era verso di registrare le estensioni al nuovo launcher di X-LibO 3.4.4

ho dovuto copiare il vecchio launcher di X-LibO 3.3.3 per far funzionare il programma
Back to top
barta
Sun 13 Nov 2011 - 11:43

online
Registered Member #4207
Joined: Tue 17 Apr 2007 - 16:50
Posts: 291
Mi spiego meglio così mi dite se ho fatto qualcosa di scorretto.

Io uso X-LibO su PC fisso come sostituto della versione da installare.

Di fatto scarico il vostro file, lo scompatto e poi ultimo la procedura di inizializzazione.

Poi manualmente assegno le estensioni dei file affinchè siano aperte dal launcher X-LibreOffice.exe

per cui ad ogni upgrade non faccio altro che sostituire in toto la cartella con la vecchia versione con quella contenente la nuova.

Mettendole sempre nella stessa posizione del disco, anche se i file sono diversi non ho mai avuto problemi nella “memoria” delle estensioni... ovvero il file X-LibreOffice.exe era sempre nella stessa posizione pur provenendo da un diverso pacchetto.

Stranamente su Vista 64bit con l'upgrade alla 3.4.4 il nuovo launcher, pur avendo lo stesso nome e la stessa posizione di quello della 3.3.3 non veniva riconosciuto dal sistema per aprire i files come applicazione di default...

ho provato anche di riconfiguralo manualmente ma purtroppo il nuovo laungher non rimaneva selezionabile dal menu “apri con”

come detto prima l'unica soluzione possibile è stata sostituire il launcher della 3.4.4 con quello della 3.3.3 ed adesso tutto funziona

come mai questo comportamento? È forse colpa di Vista che come Win7 è molto più rognoso e delicato nell'assegnazione delle estensioni di default rispetto a quanto non era Xp?
Back to top

Moderators: Danix, Taf, Rcs, Energy, zandet2, ZioZione, Admin, LordJim60

Jump:     Back to top

Syndicate this thread: rss 0.92 Syndicate this thread: rss 2.0 Syndicate this thread: RDF
Powered by e107 Forum System