Menù Principale

Cerca
Login
Registrati
Link
<< Discussione precedente | Discussione successiva >>   
Aggiornamento: [librerie] Java SE Runtime Environment

Vai a pagina   <<        >>  
Autore Messaggio
Danix
lun 20 ott 2014 - 16:47

online

Utente registrato #1
Registrato il: ven 29 dic 2006 - 05:38
Provenienza: Sassari
Messaggi: 12926
Benvenuta!
Ho appena notato che il problema capita anche a me.
E' molto strano però che Java non funzioni se hai copiato le due cartelle "bin" e "lib" nella directory corretta.
Hai detto di aver scaricato il wpp full. Se ad esempio esegui "X-RSSOwl" dal menù, il programma (è un lettore di feed RSS) si avvia? Puoi fare la stessa prova con "X-muCommander" (file manager).
Torna ad inizio pagina
Sito Web
Danix
lun 20 ott 2014 - 17:15

online

Utente registrato #1
Registrato il: ven 29 dic 2006 - 05:38
Provenienza: Sassari
Messaggi: 12926
Ok, capito.. i pacchetti devono essere aggiornati.. sono troppo vecchi.
Presumo che il problema sia capitato durante l'installazione di X-LibreOffice, giusto?

Segui la procedura seguente:
  1. da \winPenPack\Bin elimina la cartella "LibreOffice 4"
  2. Installa la nuova versione di X-LibreOffice -Link- nel pacchetto seguendo questa procedura -Link-
  3. riesegui X-LibreOffice dal menù
  4. fai sapere se tutto è andato a buon fine
Torna ad inizio pagina
Sito Web
francescavet
lun 20 ott 2014 - 19:01

online
Utente registrato #41813
Registrato il: ven 17 ott 2014 - 16:21
Messaggi: 4
Grazie di aver risposto Danix !
si, i due X SW che mi hai suggerito si aprono regolarmente ed anche gli altri che ho avviato un po' a casaccio un po' per curiosità... in effetti mi capita con Libre office, anche con le macro niente da fare.
Sto scaricando e rinstallando LO come mi hai suggerito, appena finisce il download (grazie Italia per le connessioni "fast") ti faccio sapere.
Torna ad inizio pagina
francescavet
lun 20 ott 2014 - 19:48

online
Utente registrato #41813
Registrato il: ven 17 ott 2014 - 16:21
Messaggi: 4
... Niente da fare..... le procedure guidate dei formulari e delle ricerche di dbase mi fanno arrivare alla fine ma non riesco a salvarle .... però al primo avvio di LO non è partito il download di JRE nè è apparso il solito messaggio "impossibile istallare java".
E ora in wpp/lib/java ci sono dei file che allego ...
non so proprio..

Torna ad inizio pagina
Danix
lun 20 ott 2014 - 20:44

online

Utente registrato #1
Registrato il: ven 29 dic 2006 - 05:38
Provenienza: Sassari
Messaggi: 12926
Ho l'impressione che stiamo parlando di due problemi distinti:

  • Uno riguarda LO e "le procedure guidate dei formulari e delle ricerche di dbase"
  • L'altro riguarda Java

Per il primo non saprei, dovrei testare. Scrivimi i passaggi che fai tu, così provo a ripeterli.
Per quanto riguarda Java, se non è partito il download è altamente probabile che nel suo sistema sia già installato Java.
Torna ad inizio pagina
Sito Web
francescavet
lun 20 ott 2014 - 23:19

online
Utente registrato #41813
Registrato il: ven 17 ott 2014 - 16:21
Messaggi: 4
Grazie della tua pazienza..
non so, è che ho letto su vari blog che l'assenza di java può dare questi problemi soprattutto col dbase, di conseguenza ho associato le due evenienze.
Comunque si, ho java su tutti e due i miei pc e nessun problema con base di Openoffice, anche se lo uso da poco. Difatti, come ti dicevo prima, preparo i formulari su OO 4.0.1 (stessa identica procedura) e poi me li porto in giro con wpp..
Appena possibile posto la procedura che seguo io, intanto ti ringrazio dell'aiuto e ti auguro buona notte.
Torna ad inizio pagina
Nuvolari
mar 21 ott 2014 - 08:13

online
Utente registrato #4173
Registrato il: lun 16 apr 2007 - 12:27
Messaggi: 294
zandet2 ha scritto ...

Il problema è determinato dalla versione command line di 7zip (7za) utilizzata per estrarre il setup, che non riesce a processare correttamente il file.

ciao zandet2, mi era sfuggito questo tuo post e credo che sia la soluzione anche al mio problema http://www.winpenpack.com/main/e107_plugins/forum/forum_viewtopic.php?59066.post, potresti ripetermi i passi da seguire per cortesia? Non mi è chiaro questo pezzo:

zandet2 ha scritto ...

Se la versione command line (7za.exe) con la versione standard (7z.exe / 7z.dll) rinominandola, funziona tutto correttamente.

grazie


EDIT: combinando l'indicazione di zandet2 con i recenti suggerimenti di Danix, credo di aver capito più o meno il nocciolo del mio problema, seppure dovrò attendere la prossima release del JRE per avere certezza di aver risolto, scrivo il mio caso a beneficio di coloro che si dovessero trovare in una situazione analoga.

- ho eseguito correttamente l'update automatico tramite WPP fino alla versione JRE U55 utilizzando un vecchio launcher (1.4.2) di X-Sweethome3D, che dall' Update successivo del JRE non ha più funzionato dando immediatamente il messaggio "impossibile installare Java"
- ho scaricato X-Rssowl appena aggiornato (launcher 1.5.4) che credo utilizzi i nuovi files 7z.exe e 7z.dll e provato ad aggiornare il JRE; lì per lì sembrava funzionare, l'elaborazione è durata qualche minuto ma si è comunque conclusa con il messaggio "impossibile installare Java" ed un successivo messaggio di errore nel localizzare il file "..\Java\lib\i386\jvm.cfg" che in effetti nella mia U55 di partenza non c'è

Credo che il mio problema sia dovuto sì all'utilizzo di un vecchio launcher (1.4.2) ed il conseguente vecchio 7za.exe ma anche probabilmente ad una condizione di "non allineamento", essendo rimasto forse troppo indietro (U55).

A questo punto ho eseguito "manualmente" l'aggiornamento alla U71 tramite copia da PC ed ho notato che la nuova versione contiene il file "..\Java\lib\i386\jvm.cfg". Ora attendo fiducioso la pubblicazione della prossima release per eseguire un laucher 1.5.4 (come Rssowl) per avere la controprova di aver risolto. Scriverò il risultato


[ Modificato mer 22 ott 2014 - 10:43 ]
Torna ad inizio pagina
Rcs
sab 24 gen 2015 - 14:35

online

Utente registrato #675
Registrato il: mar 23 gen 2007 - 23:49
Provenienza: Salvitelle (Sa)
Messaggi: 12717
Java SE Runtime Environment 8 Update 31
Link winPenPack

Aggiornamento dalla versione 7 Update 71 alla 8 Update 31

Home: -Link-
Direct link (32 bit): -Link-
Direct link (64 bit): -Link-




Avviso di fine degli aggiornamenti pubblici per Java SE 7 A partire dal mese di aprile 2015, Oracle non inserirà più gli aggiornamenti di Java SE 7 nei propri siti di download pubblici.


Java SE Runtime Environment 7 Update 75
Direct link: -Link-

[ Modificato sab 24 gen 2015 - 14:38 ]
Torna ad inizio pagina
Danix
lun 02 feb 2015 - 12:03

online

Utente registrato #1
Registrato il: ven 29 dic 2006 - 05:38
Provenienza: Sassari
Messaggi: 12926
Rcs, per il momento non aggiorniamo la pagina di Java altrimenti il launcher va in errore.
Rimaniamo alla 7 Update 75.
Dobbiamo cercare di risolvere per Java 8.

P.S.: ho chiuso la discussione. Se devi scrivere riaprila e poi chiudila.

[ Modificato lun 02 feb 2015 - 16:40 ]
Torna ad inizio pagina
Sito Web
Rcs
dom 15 mar 2015 - 09:42

online

Utente registrato #675
Registrato il: mar 23 gen 2007 - 23:49
Provenienza: Salvitelle (Sa)
Messaggi: 12717
Java SE Runtime Environment 8 Update 40
Link winPenPack

Aggiornamento dalla versione 8 Update 31 alla 8 Update 40

Home: -Link-
Direct link (32 bit): -Link-
Direct link (64 bit): -Link-




Avviso di fine degli aggiornamenti pubblici per Java SE 7 A partire dal mese di aprile 2015, Oracle non inserirà più gli aggiornamenti di Java SE 7 nei propri siti di download pubblici.


Java SE Runtime Environment 7 Update 75
Direct link: -Link-
Torna ad inizio pagina

Vai a pagina   <<        >>  
Moderatori: Danix, Taf, Rcs, Energy, zandet2, ZioZione, Admin, LordJim60

Salta:     Torna ad inizio pagina

RSS discussione: rss 0.92 RSS discussione: rss 2.0 RSS discussione: RDF
Powered by e107 Forum System