Menù Principale

Cerca
Login
Registrati
Link sponsorizzati
<< Discussione precedente | Discussione successiva >>   
X-Gimp (rev14) test richiesto

Autore Messaggio
Danix
lun 11 mag 2009 - 00:39

online

Utente registrato #1
Registrato il: ven 29 dic 2006 - 05:38
Provenienza: Sassari
Messaggi: 12847

Avrei bisogno di un riscontro per il nuovo X-Gimp launcher che dovrebbe velocizzare notevolmente l'avvio dell'applicazione.

Il test può essere effettuato:
  1. installando direttamente il launcher sopra il precedente (rev13), spostando in un'altra partizione (o in una diversa directory) la cartella che contiene X-Gimp ed avviando X-Gimp.exe
  2. sovrascrivendo il launcher, cancellando la cartella \User\Gimp ed avviando X-Gimp.exe
x-gimp_2.6.6_rev14.zip

[ Modificato lun 11 mag 2009 - 00:40 ]
Torna ad inizio pagina
Sito Web
Taf
lun 11 mag 2009 - 11:38

online

Utente registrato #251
Registrato il: lun 22 gen 2007 - 10:12
Provenienza: Buttrio (UD)
Messaggi: 3226
Provato.... Una scheggia!

PS: io ho fatto la prova con la 2.6.3

Bravo Danix!

..ora mi scarico la 2.6.6 e faccio il test anche con quella!

[ Modificato lun 11 mag 2009 - 11:40 ]
Torna ad inizio pagina
Taf
lun 11 mag 2009 - 12:05

online

Utente registrato #251
Registrato il: lun 22 gen 2007 - 10:12
Provenienza: Buttrio (UD)
Messaggi: 3226
Test effettuato sulla 2.6.6:

a) TEST effettuato su HD di macchina Desktop Veloce (XP Pro SP3 con i7 920 2,67 GHz - 3Gb Ram)

Con Launcher REV13 e profilo utente assente --> operativo in 11/12 secondi

Con Launcher REV14 e profilo utente assente --> operativo in 5/6 secondi

-----EDIT1----

b) TEST effettuato su PenDrive CRUZER 16Gb (quella *GIFT*! collegata su Dektop i7 920 2,67 GHz)

Con Launcher REV13 e profilo utente assente --> operativo in 25/26 secondi

Con Launcher REV14 e profilo utente assente --> operativo in 8/9 secondi !!!

----- EDIT2-----

c) TEST effettuato su PenDrive CRUZER 16Gb (sempre quella! collegata su Notebook con Xp Pro SP3 e Core 2 T2400 1,83GHz - 3Gb ram)

Con Launcher REV13 e profilo utente assente --> operativo in 37/38 secondi

Con Launcher REV14 e profilo utente assente --> operativo in 9/10 secondi !!!


COMPLIMENTISSIMI Danix!!!!!!




[ Modificato lun 11 mag 2009 - 12:21 ]
Torna ad inizio pagina
Danix
lun 11 mag 2009 - 12:13

online

Utente registrato #1
Registrato il: ven 29 dic 2006 - 05:38
Provenienza: Sassari
Messaggi: 12847
Bene!
Il problema stava nel file pluginrc del profilo dove ad ogni avvio veniva riscritta l'intera mappa dei plugin, percorso per percorso. Ora i percorsi vengono corretti dall'esterno e Gimp non deve quindi andare a cercare i singoli plugin per poi aggiornare i relativi percorsi nel file di configurazione, perchè li trova già.

Off topic: questo è il mio 8888 esimo messaggio



[ Modificato lun 11 mag 2009 - 12:18 ]
Torna ad inizio pagina
Sito Web
Taf
lun 11 mag 2009 - 12:21

online

Utente registrato #251
Registrato il: lun 22 gen 2007 - 10:12
Provenienza: Buttrio (UD)
Messaggi: 3226
ho fatto un altro test! Leggi sopra...
Torna ad inizio pagina
Danix
lun 11 mag 2009 - 12:24

online

Utente registrato #1
Registrato il: ven 29 dic 2006 - 05:38
Provenienza: Sassari
Messaggi: 12847
Sì, anche per me i tempi sono più o meno quelli.
Il problema era evidente soprattutto su pendrive nel passaggio da un drive all'altro con lettera unità diversa o su un altro computer, dove i plugin dovevano essere ricaricati ogni volta. Ora i tempi di avvio si sono ridotti a 1/4.

[ Modificato lun 11 mag 2009 - 12:25 ]
Torna ad inizio pagina
Sito Web
ZioZione
lun 11 mag 2009 - 13:37
online

Utente registrato #74
Registrato il: dom 21 gen 2007 - 11:31
Provenienza: Tradate (VA)
Messaggi: 3821
Ciao Danix,
pur avendo una vecchia versione (Gimp 2.6.4, quella del pack 3.5.2), ho fatto anch'io il test richiesto.

TEST effettuato su PenDrive CRUZER 16Gb collegata su desktop con Xp Pro SP3 - Intel Pentium 4 3GHz - 2Gb ram (non ridete, è il PC su cui lavoro... )

Con Launcher REV11 e profilo utente assente --> operativo in 1'16"
Con Launcher REV14 e profilo utente assente --> operativo in 42"

Ci mette, comunque, poco più della metà del tempo: veramente notevole
Queste RE si stanno rivelando una vera manna dal cielo
Cordialmente
ZioZione
Torna ad inizio pagina
Rcs
lun 11 mag 2009 - 14:41

online

Utente registrato #675
Registrato il: mar 23 gen 2007 - 23:49
Provenienza: Salvitelle (Sa)
Messaggi: 12717
Ciao ragazzi, anch'io ho testato la nuova versione del Launcher, ecco i miei risultati:

PenDrive Verbatim 4 Gb - XP Media Center Edition SP2- Intel Pentium M 1.73 - 1 Gb ram

X-Gimp 2.6.6

Launcher REV12 e profilo utente assente --> operativo in 1'12"
Launcher REV14 e profilo utente assente --> operativo in 13"

Veramente impressionante il nuovo TURBO Launcher
Torna ad inizio pagina
NaM
lun 11 mag 2009 - 19:20

online
Utente registrato #17768
Registrato il: lun 16 mar 2009 - 12:26
Provenienza: Cesena (FC)
Messaggi: 9
Danix ha scritto ...

Avrei bisogno di un riscontro per il nuovo X-Gimp launcher che dovrebbe velocizzare notevolmente l'avvio dell'applicazione.

Provato.
Veramente impressionante la velocita' di esecuzione anche al primo start senza la cartella del profilo.
L'ho provato con un drive virtuale TrueCrypt dove al lavoro ho messo tutto il contenuto della mia chiavetta WinPenPack e la partenza rispetto a prima e' a razzo.
Complimenti Danix. Veramente un gran bel lavoro.
Grazie.
Torna ad inizio pagina

Moderatori: Danix, Taf, Rcs, Energy, zandet2, ZioZione, Admin, LordJim60

Salta:     Torna ad inizio pagina

RSS discussione: rss 0.92 RSS discussione: rss 2.0 RSS discussione: RDF
Powered by e107 Forum System