Main menu

Search
Login
Signup
Links
<< Previous thread | Next thread >>   
[Fixed] ClearProg

Author Post
Darklight79
Wed 09 Jan 2008 - 17:38

online
Registered Member #1005
Joined: Thu 25 Jan 2007 - 16:48
Location: Cesena (FC)
Posts: 111

Nome del software: ClearProg 1.5.1 Beta1

Link alla pagina di download: -Link-

Motivazione della NON portatilità:

aggiunge le seguenti chiavi di registro:

HKEY_CURRENT_USER\Software\ClearProg

Se le cancello, queste vengono ricreate.

Se al primo avvio, come suggerito, seleziono File >> Esporta impostazioni in un file INI, viene creato il file ClearProg.ini all'interno della cartella del programma, ma le impostazioni vengono ugualmente salvate nel registro.

[ Edited Fri 11 Jan 2008 - 10:45 ]
Back to top
Darklight79
Wed 09 Jan 2008 - 17:43

online
Registered Member #1005
Joined: Thu 25 Jan 2007 - 16:48
Location: Cesena (FC)
Posts: 111
Bisogna modificare manualmente all'interno del file ClearProg.ini il valore UseIni=0 con UseIni=1 poi salvare e cancellare solo la prima volta la chiave di registro.

In questo caso le impostazioni vengono salvate nel file ini e non nel registro.
Back to top
Danix
Wed 09 Jan 2008 - 17:51

online

Registered Member #1
Joined: Fri 29 Dec 2006 - 05:38
Location: Sassari
Posts: 12908
Quindi le indicazioni della pagina di download non sono corrette?
Non è sufficiente: Portable tips how-to: al primo avvio selezionare File >> Esporta impostazioni in un file INI. Verrà così creato il file ClearProg.ini all'interno della cartella del programma. Viceversa le impostazioni verranno salvate nel registro!
Back to top
Website
ZioZione
Wed 09 Jan 2008 - 17:55
online

Registered Member #74
Joined: Sun 21 Jan 2007 - 11:31
Location: Tradate (VA)
Posts: 3821
Ciao Darklight,
confermo.
Sembra che non riesca a salvare l'opzione "Esporta impostazioni in un file INI" (dovrebbe essere alterna con "Esporta impostazioni nel registro". Probabilmente è un baco del programma, perché basta aprire il file .ini e mettere

UseIni=1

e da quel momento funziona senza sporcare il registro.
Sarebbe da segnalare all'autore, ma forse è un problemino della beta...
Cordialmente
ZioZione

EDIT: scusa, stavo scrivendo e non mi sono accorto che avevi già segnalato tu...

[ Edited Wed 09 Jan 2008 - 17:57 ]
Back to top
Darklight79
Wed 09 Jan 2008 - 18:10

online
Registered Member #1005
Joined: Thu 25 Jan 2007 - 16:48
Location: Cesena (FC)
Posts: 111
Ho provato anche con la versione 1.5.0 Final, ma con gli stessi risultati.
Penso che le indicazioni portable tips how-to vadano integrate con quanto detto sopra.
Back to top
ZioZione
Thu 10 Jan 2008 - 08:28
online

Registered Member #74
Joined: Sun 21 Jan 2007 - 11:31
Location: Tradate (VA)
Posts: 3821
Ciao Darklight79,
concordo, magari semplificandole un po'...

Prima del primo avvio creare il file ClearProg.ini così fatto:

[ClearProg]
UseIni=1

In questo modo le impostazioni verranno salvate nel file .ini e non nel registro.


Cordialmente
ZioZione
Back to top

Moderators: Danix, Taf, Rcs, Energy, zandet2, ZioZione, Admin, LordJim60

Jump:     Back to top

Syndicate this thread: rss 0.92 Syndicate this thread: rss 2.0 Syndicate this thread: RDF
Powered by e107 Forum System