Main menu

Search
Login
Signup
Links
<< Previous thread | Next thread >>   
Bug rilevati in winPenPack 3.6/Testing

Go to page       >>  
Author Post
Danix
Sat 28 Nov 2009 - 02:00

online

Registered Member #1
Joined: Fri 29 Dec 2006 - 05:38
Location: Sassari
Posts: 12898


-------------------------------------------
winPenPack 3.6 BUG RILEVATI/TESTING
-------------------------------------------


Ti saremo grati se vorrai segnalare in questo topic qualsiasi bug o problema riscontrato nella nuova versione 3.6 di winPenPack.
Grazie!

We invite you to signal us all eventual bugs or problems found in winPenPack 3.6 version.
Thanks!

[ Edited Sat 26 Mar 2011 - 14:33 ]
Back to top
Website
Danix
Sun 06 Dec 2009 - 20:19

online

Registered Member #1
Joined: Fri 29 Dec 2006 - 05:38
Location: Sassari
Posts: 12898
Due BUG GRAVI che riguardano X-muCommander (nel wpp_2gb) e X-GEONExT (nel wpp_school). Forse riusciamo ancora a sostituire i pack sui server.

Chi ha effettuato il download prima di oggi (7 Dicembre), può scaricare i fix allegati (da installare tramite l'opzione "Installa X-Software.." del menù) o modificare manualmente i file INI nel modo seguente:


FIX:

x-mucommander_launcher_1.4_rev3.zip
x-geonext_launcher_1.4_rev5.zip

Nota: dopo l'installazione del nuovo X-Geonext_launcher nel winPenPack School, è necessario cancellare anche il file X-GEONeXT.ini dalle cartelle XDrive/en e XDrive/it

[ Edited Tue 08 Dec 2009 - 03:46 ]
Back to top
Website
Ketty
Mon 07 Dec 2009 - 03:45
online
Registered Member #5089
Joined: Sat 09 Jun 2007 - 02:27
Posts: 1461
Danix wrote ...

Due BUG GRAVI: al momento i due programmi NON SONO PORTATILI (i profili non vengono salvati in \User):

(2gb) X-muCommander

Parameters=-Duser.home="muCommanderProfileDir" -jar muCommander.jar

da correggere in:

Parameters=-Duser.home="%muCommanderProfileDir%" -jar muCommander.jar



Sei proprio sicuro danix? Perchè (i log dei test ce li ho tutti ) col regshot ho:

File aggiunti:
G:\wpp_2gb_3.6\winPenPack\User\muCommander\.mucommander\action_keymap.xml
G:\wpp_2gb_3.6\winPenPack\User\muCommander\.mucommander\bookmarks.xml
G:\wpp_2gb_3.6\winPenPack\User\muCommander\.mucommander\preferences.xml
G:\wpp_2gb_3.6\winPenPack\User\muCommander\.mucommander\shell_history.xml


Cartelle aggiunte:
G:\wpp_2gb_3.6\winPenPack\User\muCommander
G:\wpp_2gb_3.6\winPenPack\User\muCommander\.mucommander
G:\wpp_2gb_3.6\winPenPack\User\muCommander\.mucommander\extensions
G:\wpp_2gb_3.6\winPenPack\User\muCommander\.mucommander\themes


Non è una scusante, se ho sbagliato, ho sbagliato e mi assumo le mie responsabilità
Back to top
Danix
Mon 07 Dec 2009 - 03:53

online

Registered Member #1
Joined: Fri 29 Dec 2006 - 05:38
Location: Sassari
Posts: 12898
Purtroppo sono sicuro. Le variabili inserite nei parametri non vengono riconosciute, perchè per distrazione ho sbagliato la sintassi (ho scritto muCommanderProfileDir anzichè %muCommanderProfileDir%).
Ad esempio muCommander ha un comportamento non previsto, non mostra lo splash screen, ha una grafica diversa da quella che avevo impostato, etc..
In pratica \User\muCommander non viene riconosciuta come cartella del profilo.

G:\wpp_2gb_3.6\winPenPack\User\muCommander
G:\wpp_2gb_3.6\winPenPack\User\muCommander\.mucommander
G:\wpp_2gb_3.6\winPenPack\User\muCommander\.mucommander\extensions
G:\wpp_2gb_3.6\winPenPack\User\muCommander\.mucommander\themes

Mi sa che tu hai il log della beta 1 e non del secondo pacchetto, dove appunto ho fatto le modifiche agli INI per il nuovo sistema di decompressione del setup di Java

[ Edited Mon 07 Dec 2009 - 03:56 ]
Back to top
Website
Ketty
Mon 07 Dec 2009 - 04:01
online
Registered Member #5089
Joined: Sat 09 Jun 2007 - 02:27
Posts: 1461
Ahhhh ho capito che intendi, almeno credo.

Purtroppo non ho fatto i test anche per controllare se manteneva le impostazioni al cambio drive
Mi dispiace


Edit
Sì è il log della prima suite

[ Edited Mon 07 Dec 2009 - 04:02 ]
Back to top
Danix
Mon 07 Dec 2009 - 04:13

online

Registered Member #1
Joined: Fri 29 Dec 2006 - 05:38
Location: Sassari
Posts: 12898
Ketty wrote ...

Purtroppo non ho fatto i test anche per controllare se manteneva le impostazioni al cambio drive
Mi dispiace

No, non è quello. Diciamo che questi due bug erano davvero difficili da trovare.
Apparentemente i profili venivano creati in \User\NomeProgramma (sia per un programma che per l'altro), ma in realtà solo in modo artificioso (tramite la copia di un file x-default per le impostazioni o tramite la scrittura di una stringa con WriteToFile). Comunque, nella speranza che non ce ne siano altri, il problema ora dovrebbe essere risolto. Ho ricaricato i file corretti (da 800/900 MB ciascuno ) sui server.

[ Edited Mon 07 Dec 2009 - 04:15 ]
Back to top
Website
cafeina
Wed 12 May 2010 - 18:00
online
Registered Member #38731
Joined: Wed 12 May 2010 - 17:56
Posts: 4
Io ho incontrato grossi problemi con la versione exe sotto windows 7 Pro. Il disco inizia a lavorare pesantemente per un periodo lunghissimo di tempo ma senza alcun risultato. Oggi l'ho lasciato anche 3 ore ma niente. Durante uno dei tentativi è partito UAC, ma poi nulla...
Back to top
Danix
Wed 12 May 2010 - 19:54

online

Registered Member #1
Joined: Fri 29 Dec 2006 - 05:38
Location: Sassari
Posts: 12898
cafeina wrote ...

Oggi l'ho lasciato anche 3 ore ma niente.

L'hai lasciato 3 ore a far cosa?
Parli dell'installazione? In questo caso forse non hai i diritti amministrativi sul computer in uso (prova la versione in formato ZIP).
Oppure parli dell'esecuzione del menù? Sarebbe utile sapere che operazioni hai fatto a partire dal momento in cui lo hai scaricato.

P.S.: io uso normalmente winpenpack su Windows 7, senza problemi.


[ Edited Wed 12 May 2010 - 20:04 ]
Back to top
Website
cafeina
Thu 13 May 2010 - 13:37
online
Registered Member #38731
Joined: Wed 12 May 2010 - 17:56
Posts: 4
Allora...

1) sono amministratore della macchina

2) 3 ore a partire da quando ho lanciato l'eseguibile da utente amministratore

La volta che è parttito l'UAC era un tentativo fatto con un altro utente che però faceva parte del gruppo administrators.

Prima di winpenpack avevo portableapps e non ho mai avuto problemi con quel eseguibile, da qui la mia conclusione che è un problema di winpenpack.

Un'ultima cosa...io ho tentato l'installazione da utente che ha i privilegi di amministratore, ma se vado a leggere modalità di utilizzo vedo questo:

"In entrambi i casi nessun dato verrà scritto nel registro di Windows e nelle cartelle utente, e poichè le operazioni di installazione o estrazione non richiedono i diritti amministrativi sul computer in uso, winPenPack potrà essere installato ed eseguito anche su computer sui quali si ha l'accesso solo ad account limitati."


Mi sa che torno a portableapps. L'ho appena reinstallato senza alcun problema.
Peccato perchè winpenpack ha qualche applicazione in più..

[ Edited Thu 13 May 2010 - 14:05 ]
Back to top
Danix
Thu 13 May 2010 - 20:06

online

Registered Member #1
Joined: Fri 29 Dec 2006 - 05:38
Location: Sassari
Posts: 12898
Ok, quindi si tratta dell'installazione.
Onestamente non ho mai provato l'installazione su Windows 7, appena e se potrò lo farò.

Mi sa che torno a portableapps.

Siamo in democrazia.
Back to top
Website

Go to page       >>  
Moderators: Danix, Taf, Rcs, Energy, zandet2, ZioZione, Admin, LordJim60

Jump:     Back to top

Syndicate this thread: rss 0.92 Syndicate this thread: rss 2.0 Syndicate this thread: RDF
Powered by e107 Forum System