Main menu

Search
Login
Signup
Links
<< Previous thread | Next thread >>   
X-Iron e plugin flash player

Go to page   <<        >>  
Author Post
dito
Wed 28 Nov 2012 - 12:44

online
Registered Member #11533
Joined: Sat 31 May 2008 - 09:32
Posts: 196
Qualcuno ha esperienze con Gnash Player? -Link- ; -Link-

Gnash under Windows XP: -Link-

Grazie e ciao

[ Edited Thu 29 Nov 2012 - 22:50 ]
Back to top
dito
Sat 13 Apr 2013 - 09:21

online
Registered Member #11533
Joined: Sat 31 May 2008 - 09:32
Posts: 196
Bourne wrote ...

Da qualche versione Google sconsiglia l'uso del flash di Adobe (npapi) e rilascia Chrome non più con quel plugin ma con il suo plugin "nativo", chiamato pepperflash che usa un'api più sicura, ppapi, che gira "out of process" (lo si può notare in about:plugins). Tale plugin funziona solo su Chrome e altri fork di Chromium.
Comunque, in vari casi che non siano Chrome, tale plugin va caricato manualmente (il plugin l'ho preso da un chrome portable), così ho fatto con il mio Dragon (un altro fork) e così deve fare anche chi usa Iron (almeno da quanto verificato con un amico).

Il parametro che ho aggiunto all'eseguibile principale del browser portable che uso è il seguente:

--ppapi-flash-path=.\PepperFlash\pepflashplayer.dll --ppapi-flash-version=11.5.31.2


Ora, nel caso invece di chi usa X-Iron e supponendo che la cartella PepperFlash sia stata inserita nella medesima directory dove è presente il file Iron.exe, questo dovrebbe essere il comando da aggiungere all'X-Iron.ini in "Parameters" di [FileToRun]:

--ppapi-flash-path=$Bin$\$AppName$\PepperFlash\pepflashplayer.dll --ppapi-flash-version=11.5.31.2


In allegato ho inserito la versione di PepperFlash presente nell'ultima versione stable di Chrome.




pepperflash.rar


Grazie Bourne,
ma nel caso di X-Firefox c'è qualcosa che si possa fare in Windows Seven (32 e 64bit), visto che nemmeno le ultime versioni (11.7) del flash Player portable funzionano, mentre per l'ultima funzionante (11.2) viene segnalato un problema di sicurezza e viene disattivato automaticamente il plugin?

Ancora grazie.

dito
Back to top
Bourne
Sat 13 Apr 2013 - 14:08

online
Registered Member #4287
Joined: Fri 20 Apr 2007 - 16:55
Posts: 570
dito wrote ...

ma nel caso di X-Firefox c'è qualcosa che si possa fare in Windows Seven (32 e 64bit), visto che nemmeno le ultime versioni (11.7) del flash Player portable funzionano, mentre per l'ultima funzionante (11.2) viene segnalato un problema di sicurezza e viene disattivato automaticamente il plugin?

Che io sappia il flash plugin (npapi, il ppapi esiste solo per chrome e cloni) per firefox funziona a dovere, ultima versione inclusa. Quando qualcuno riscontra dei problemi solitamente la causa risiede nel supporto all'accelerazione hardware che magari non è supportata dall'hardware dell'utente (e allora in tal caso bisogna disattivarla nelle preferenze del plugin flash).

Comunque, io ti consiglio Pale Moon al posto di Firefox: non è un mero porting dai sorgenti di firefox, ci sono varie ottimizzazioni e attenzioni (sul forum) a certi particolari (e a parità di numero di release tra i due, pale moon a volte si diversifica per inserimento di aggiunte/patch/fix o esclusione di funzioni/feature che sul momento si siano rivelate acerbe/problematiche).

In versione portable esiste sia a 32 che a 64 bit: -Link-

Utilizzano il medesimo X-Launcher di Winpenpack ma, lo sviluppatore non essendo esperto di tale launcher, lascia fuori alcune cose che, anche se di pochissima importanza (visto che in tali luoghi non viene memorizzato alcunché che annulli la portabilità), per avere un qualcosa di pulitissimo avevo chiesto l'aiuto di qualcuno qua su winpenpack (non mi hanno cagato nemmeno di striscio ), esattamente a tale pagina -Link-

Concludendo, se usi la versione a 32 bit del browser, usa il plugin flash "NPSWF32.dll", se invece è 64bit, usa "NPSWF64.dll".
Back to top
dito
Sun 14 Apr 2013 - 21:22

online
Registered Member #11533
Joined: Sat 31 May 2008 - 09:32
Posts: 196
@Bourne
stò provando Dragon, ma devo chiederti un paio di chiarimenti:

1. come e/o dove si deve caricare il plugin pepperflash (che ho scaricato) in Dragon?
2. dove si deve inserire (mi servirebbero istruzioni precise) il parametro "--ppapi-flash-path=.\PepperFlash\pepflashplayer.dll --ppapi-flash-version=11.5.31.2"?

Grazie mille.
Back to top
Bourne
Mon 15 Apr 2013 - 08:11

online
Registered Member #4287
Joined: Fri 20 Apr 2007 - 16:55
Posts: 570
dito wrote ...

@Bourne
stò provando Dragon, ma devo chiederti un paio di chiarimenti:

1. come e/o dove si deve caricare il plugin pepperflash (che ho scaricato) in Dragon?
2. dove si deve inserire (mi servirebbero istruzioni precise) il parametro "--ppapi-flash-path=.\PepperFlash\pepflashplayer.dll --ppapi-flash-version=11.5.31.2"?

I comandi a linea comando vanno inseriti come parametri dell'eseguibile principale (vale per tutti i programmi che necessitano di partire con appropriati comandi), quindi (ho inserito anche l'ultima versione del pepper flash):
dragon.exe --ppapi-flash-path=.\PepperFlash\pepflashplayer.dll --ppapi-flash-version=11.7.700.179

puoi inserire la summenzionata stringa (il path specificato è un path relativo che punta alla cartella PepperFlash, situata nella medesima directory dove si trova dragon.exe e la quale contiene i due file manifest.json e pepflashplayer.dll) manualmente nella console, o in un file batch, o nel collegamento al programma (per comodità potresti inserire tale collegamento a dragon.exe direttamente sul desktop, poi entri nelle proprietà del collegamento e invece di lasciargli solo dragon.exe gli aggiungi tutta la summenzionata linea).


Occhio che l'attuale dragon si basa sulla penultima versione stable 26 di chrome, la quale ha dei problemini; tra poco dovrebbe uscire la versione aggiornata.
Back to top
dito
Mon 15 Apr 2013 - 19:18

online
Registered Member #11533
Joined: Sat 31 May 2008 - 09:32
Posts: 196
Bourne wrote ...

dito wrote ...

@Bourne
stò provando Dragon, ma devo chiederti un paio di chiarimenti:

1. come e/o dove si deve caricare il plugin pepperflash (che ho scaricato) in Dragon?
2. dove si deve inserire (mi servirebbero istruzioni precise) il parametro "--ppapi-flash-path=.\PepperFlash\pepflashplayer.dll --ppapi-flash-version=11.5.31.2"?

I comandi a linea comando vanno inseriti come parametri dell'eseguibile principale (vale per tutti i programmi che necessitano di partire con appropriati comandi), quindi (ho inserito anche l'ultima versione del pepper flash):
dragon.exe --ppapi-flash-path=.\PepperFlash\pepflashplayer.dll --ppapi-flash-version=11.7.700.179

puoi inserire la summenzionata stringa (il path specificato è un path relativo che punta alla cartella PepperFlash, situata nella medesima directory dove si trova dragon.exe e la quale contiene i due file manifest.json e pepflashplayer.dll) manualmente nella console, o in un file batch, o nel collegamento al programma (per comodità potresti inserire tale collegamento a dragon.exe direttamente sul desktop, poi entri nelle proprietà del collegamento e invece di lasciargli solo dragon.exe gli aggiungi tutta la summenzionata linea).


Occhio che l'attuale dragon si basa sulla penultima versione stable 26 di chrome, la quale ha dei problemini; tra poco dovrebbe uscire la versione aggiornata.


Grazie per la chiarezza e la precisione.

Per recuperare la versione più recente di pepflashplayer.dll (in rete ho trovato solo quella precedente, 11.5) l'unica possibilità è quella di installare Chrome?

Un cordiale saluto.
dito






[ Edited Mon 15 Apr 2013 - 19:25 ]
Back to top
Bourne
Tue 16 Apr 2013 - 05:05

online
Registered Member #4287
Joined: Fri 20 Apr 2007 - 16:55
Posts: 570
In allegato l'ultima versione.




pepperflash.7z
Back to top
zandet2
Thu 18 Apr 2013 - 17:25

online

Registered Member #3184
Joined: Tue 06 Mar 2007 - 11:52
Location: Busto Arsizio
Posts: 3301
Ho provato a usare pepperflash con x-iron, e sinceramente non capisco proprio perchè bisogna configurarlo con tutti quei parametri (addirittura esplicitare la versione!!!!).
Se è stata prevista una specifica cartella "\plugins" dove inserire appunto i plugin, perchè non basta copiarlo li dentro? Misteri da geek...

Comunque, ho visto che anche senza indicare la versione il plugin viene attivato (con una versione fittizia 11.2.999.999), non so però se questo ha impatti nella sua esecuzione; andando nella pagina di test su adobe la versione viene comunque correttamente riconosciuta.

Quindi, volendo, se si copia la dll direttamente nella cartella plugins la modifica ai parametri di lancio di X-Iron si può ridurre a questa aggiunta:

--ppapi-flash-path="%Plugins%\pepflashplayer.dll"

facendo diventare la riga così:

Parameters=--user-data-dir="%Profile%" --disk-cache-dir="$Cache$" --extra-plugin-dir="$Java$\bin\plugin2" --ppapi-flash-path="%Plugins%\PepperFlash\pepflashplayer.dll"

Ciao!
Back to top
Bourne
Thu 18 Apr 2013 - 21:41

online
Registered Member #4287
Joined: Fri 20 Apr 2007 - 16:55
Posts: 570
Sì vero (la versione la inserisco per mia abitudine e perché uso TCommander dove le linee comando si possono totalmente automatizzare) ma si stava parlando soprattutto di Dragon che non necessità di x-launcher (uno tra i motivi per cui ho lasciato iron).
Back to top
Taf
Fri 19 Apr 2013 - 08:18

online

Registered Member #251
Joined: Mon 22 Jan 2007 - 10:12
Location: Buttrio (UD)
Posts: 3292
Bourne wrote ...

.... ma si stava parlando soprattutto di Dragon che non necessità di x-launcher (uno tra i motivi per cui ho lasciato iron).

Ma Dragon è portabile nativo al 100% ?? Hai verificato il registro di sitema?
sul sito di comodo si trova la seguente frase, relativamente all'installazione portabile:
The Installer does not write anything to the Windows registry

ma, secondo me, è una frase sibillina... dice che in fase di installazione il programma non scrive nel registro.... ma durante l'utilizzo??


[ Edited Fri 19 Apr 2013 - 08:19 ]
Back to top

Go to page   <<        >>  
Moderators: Danix, Taf, Rcs, Energy, zandet2, ZioZione, Admin, LordJim60

Jump:     Back to top

Syndicate this thread: rss 0.92 Syndicate this thread: rss 2.0 Syndicate this thread: RDF
Powered by e107 Forum System