Main menu

Search
Login
Signup
Links
<< Previous thread | Next thread >>   
X-Winmerge 2.16 64 bit - non salva impostazioni?

Author Post
harmand
Fri 11 Jan 2019 - 05:07
online
Registered Member #40487
Joined: Sun 10 Jun 2012 - 06:29
Posts: 45

Ho scaricato e "installato" il file

X-WinMerge_2.16.0_win64_rev12.zip

Il programma si avvia regolarmente (in lingua inglese), ma qualsiasi modifica nelle impostazioni (Edit > Options) sembra valere solo per la sessione in corso. Chiudendo il programma e riavviandolo mi ritrovo alla situazione di partenza.
Back to top
Danix
Fri 11 Jan 2019 - 11:21

online

Registered Member #1
Joined: Fri 29 Dec 2006 - 05:38
Location: Sassari
Posts: 12898
Alcune impostazioni sono proprio "blindate" per preservare la portabilità del programma.
Se apri il file X-WinMerge.ini, vedrai alcune stringhe nella sezione seguente:

[WriteToReg=$Home$\$AppName$\$AppName$.reg]
MainKey=HKEY_CURRENT_USER\Software\Thingamahoochie
WinMerge|"Executable"=$ExeDir$\$AppName$U.exe|\\"
WinMerge\Settings|"UserFilterPath"=%WinMergeFilters%|\\"
WinMerge\Settings|"ProjectsPath"=%WinMergeProjects%|\\"
WinMerge\Settings|"CustomTempPath"=$Temp$|\\"
WinMerge\Settings|"UseSystemTempPath"=dword:00000000
WinMerge\Settings|"DisableSplash"=dword:00000001
WinMerge\Merge7z|"Enable"=dword:00000002
WinMerge\Backup|"GlobalFolder"=$Backup$\$AppName$\|\\"


Se ad esempio non vuoi che i progetti vengano salvati nella directory interna al software (\Documents\WinMerge Projects), devi aggiungere un punto e virgola all'inizio della stringa, così:

;WinMerge\Settings|"ProjectsPath"=%WinMergeProjects%|\\"


Se invece ti riferisci ad altre impostazioni, specifica meglio..
Back to top
Website
harmand
Sat 12 Jan 2019 - 08:07
online
Registered Member #40487
Joined: Sun 10 Jun 2012 - 06:29
Posts: 45
Avevo visto il contenuto del file .ini, ma mi riferivo ad altre impostazioni che normalmente vengono memorizzate in maniera stabile.
Se ad es. imposto la lingua italiana per l'interfaccia (edit > options > general > language), all'uscita dal comando il menu passa subito alla lingua italiana (come previsto) ma al successivo avvio del programma mi ritrovo di nuovo, come dicevo ieri, con l'interfaccia in inglese.
Analogamente, se nella stessa scheda attivo l'opzione "Ask when closing multiple windows", al successivo riavvio la ritrovo disattivata, mentre se rientro nel comando (senza riavviare il programma) la trovo ancora attiva.
Ho provato anche con qualche altra opzione in altre schede, con lo stesso risultato.
Sembra appunto che le scelte fatte con il comando "opzioni" valgano solo per la sessione corrente.
Back to top
Danix
Sat 12 Jan 2019 - 17:28

online

Registered Member #1
Joined: Fri 29 Dec 2006 - 05:38
Location: Sassari
Posts: 12898
A me non risulta. Tutto viene memorizzato.
Prova su un altro PC.
Back to top
Website
harmand
Sun 13 Jan 2019 - 06:59
online
Registered Member #40487
Joined: Sun 10 Jun 2012 - 06:29
Posts: 45
Al momento non ho un altro PC su cui provare.
Comunque, siccome questo PC è lo stesso su cui la versione precedente non presenta quel problema (così come anche una versione portabile di WM2011, che tempo fa avevo trovato in rete e che somiglia moltissimo a questa 2.16), avevo dedotto che la causa potesse trovarsi più probabilmente nel programma che nel computer.

Evidentemente sbagliavo.
Back to top

Moderators: Danix, Taf, Rcs, Energy, zandet2, ZioZione, Admin, LordJim60

Jump:     Back to top

Syndicate this thread: rss 0.92 Syndicate this thread: rss 2.0 Syndicate this thread: RDF
Powered by e107 Forum System