Menù Principale

Cerca
Login
Registrati
Link
<< Discussione precedente | Discussione successiva >>   
[Bug] X-Planner: problemi di stampa

Vai a pagina   <<      
Autore Messaggio
Danix
mer 09 dic 2009 - 20:30

online

Utente registrato #1
Registrato il: ven 29 dic 2006 - 05:38
Provenienza: Sassari
Messaggi: 12916
Ho aggiornato il sistema con Windows update (credo che, fra gli altri, sia stato aggiornato Microsoft Visual C++) e ora X-Planner_0.14.3_rev9 funziona, mentre la 0.14.4 mostra un errore di runtime:




[ Modificato mer 09 dic 2009 - 23:34 ]
Torna ad inizio pagina
Sito Web
Taf
gio 10 dic 2009 - 10:44

online

Utente registrato #251
Registrato il: lun 22 gen 2007 - 10:12
Provenienza: Buttrio (UD)
Messaggi: 3320
Avanzamento test:
Oggi ho scaricato la 0.4.14 e l'ho estratta con universal extractor.
sono partito dalla base X-Planner 0.14.3 ed ho sostituito la versione presente in BIN con quella nuova estratta con UE.
al primo avvio mi ha dato un messaggio di errore:
mancanza della DLL libpng13.dll

inoltre ho notato che nella versione 0.14.4 non ci sono più le seguenti dll:
X-Planner-TEST_0414\Bin\Planner\bin\libexpat.dll
X-Planner-TEST_0414\Bin\Planner\bin\libgnomeprint-2-2-0.dll
X-Planner-TEST_0414\Bin\Planner\bin\libgnomeprintui-2-2-0.dll

Ho copiato solo la dll che mi dav il messaggio di errore (la libpng13.dll)

TEST DI STAMPA:
con questa modifica, il programma apre il mio file di planning di prova e lo stampa senza problemi sia con PDF creator che con una stampante laser di rete.
Però l'anteprima di stampa non funziona!
se provo a visualizzare l'anteprima di stampa, mi parte il visulizzatore di defaut di windows:
"Visualizzatore Immagini e fax Per Windows"
che tenta di visualizzare un fantomatico file ********.emf (il nome cambia di volta in volta) e mi dice "Anteprima non disponibile"
per il resto, le altre opzioni del programma funzionano perfettamente.

PS:
anche copiando in BIN le tre dll sopra citate, il problema dell'anteprima persiste e la stampa funziona. Quindi è chiaro che queste ultime non sono più necessarie.
Mi lascia molto perplesso la mancanza della libpng13.dll dopo l'estrazione con UE della versione 0.14.4.

EDIT:

ecco il changelog della 0.14.4 :
Planner 0.14.4
==============

New features and fixes
======================

* Rewrote printing to use the GTK printing API, fixing most problems with
printing on Windows (thanks to Francisco Moraes)

* Added display of minutes to duration format
* Added creation of Windows installer to Makefiles
* Dropped support for libgda < 3.0
* Added proper quoting to SQL code (#168147, #571801)
* Fixed alignment problems in HTML export (#471218, #478027)
* Fixed a crash in UNDO/REDO code (#420443)
* Fixed several issues with the build (#528582, #528971, #529045, #539993)


per fortuna che hanno riscritto il sistema di stampa....

EDIT 2:
qui
-Link-
lo sviluppatore della versione per windows (che ha collaborato alla 0.14.4) dice:
tradotto :"Sono necessarie le GTK 2.6 o superiori"


inoltre il link di DL di questa pagina punta alla vecchia 0.14.2 !!!


[ Modificato gio 10 dic 2009 - 11:10 ]
Torna ad inizio pagina
vix
gio 10 dic 2009 - 13:28
online
Utente registrato #11044
Registrato il: sab 10 mag 2008 - 15:17
Messaggi: 27
@Taf (e p.c. @Danix e gli altri): ho fatto anch'io un po' di test in questi due giorni, e ho trovato alcune informazioni che credo possano interessare.
Premetto che sto utilizzando X-Planner da HD (in C:\PortableApps\) fuori dalla suite WPP, ma ho fatto i test usando una serie di macchine virtuali "pulite".

- Il problema di stampa e di anteprima con la 0.4.13 si presenta se la si usa con un utente che non è amministratore (nel mio caso Power User). Lanciandolo come amministratore, tutto è OK.
Ho notato, però, che la prima volta che si lancia la stampa come amministratore, il programma ci mette un po' (circa 8 secondi) prima di mostrare il popup in cui chiede che cosa stampare. Tutte le successive volte questo popup appare subito. Forse sta facendo qualche operazione che ad un utente non amministratore non è consentita? E da qui il crash...

- La 0.4.14 si comporta come descritto da Taf se la si lancia come amministratore. Da Power User c'è il messaggio di errore di runtime come descritto da Danix. Confermo anche il problema dell'anteprima (sia come amministartore che come Power User)

[ Modificato gio 10 dic 2009 - 13:29 ]
Torna ad inizio pagina
Danix
dom 28 apr 2013 - 19:20

online

Utente registrato #1
Registrato il: ven 29 dic 2006 - 05:38
Provenienza: Sassari
Messaggi: 12916
Ho caricato in questa pagina le due nuove versioni 0.4.14 e 0.4.16:

X-Planner download page

Io ottengo l'errore di runtime solo nella 0.4.16 (che tra l'altro non include più le traduzioni, a differenza delle versioni precedenti), quando vado a salvare un documento:



La 0.4.14, invece, sembra funzionare correttamente.
Qualcuno può confermare?

[ Modificato dom 28 apr 2013 - 19:21 ]
Torna ad inizio pagina
Sito Web

Vai a pagina   <<      
Moderatori: Danix, Taf, Rcs, Energy, zandet2, ZioZione, Admin, LordJim60

Salta:     Torna ad inizio pagina

RSS discussione: rss 0.92 RSS discussione: rss 2.0 RSS discussione: RDF
Powered by e107 Forum System