Menù Principale

Cerca
Login
Registrati
Link
<< Discussione precedente | Discussione successiva >>   
[Proposta] Nuovo ini per X-Mule

Vai a pagina   <<      
Autore Messaggio
tittoproject
lun 21 mag 2007 - 00:01

online
Utente registrato #821
Registrato il: mer 24 gen 2007 - 17:22
Messaggi: 592
Su eMulePlus (che uso invece di eMule), si puo' impostare un lettore multimediale via .ini (ho messo VideoLAN).
Torna ad inizio pagina
Danix
lun 21 mag 2007 - 00:56

online

Utente registrato #1
Registrato il: ven 29 dic 2006 - 05:38
Provenienza: Sassari
Messaggi: 12935
Anche su eMule normale:


[WriteToIni=$ExeDir$\config\preferences.ini]
eMule|VideoPlayer=@ScriptDir@\X-VideoLAN.exe


Solo che, come dicevo, rimane come impostazione fissa.
Al limite potrei creare una variabile eMULE_PLAYER da impostare nell'ini, ma richiederebbe sempre l'intervento dell'utente sul X-Mule.ini

Se solo si potesse utilizzare un "if" come nel php: se X-VideoLan è presente eMule lo utilizza, altrimenti si può impostare..


---- edit ----

L'unica soluzione che ho trovato è la seguente.
Prevede la scelta fra 3 players (MPClassic, MPlayer e X-Videolan) che però si trovano in posizioni diverse.
Infatti X-VideoLAN sta in root o in XDrive, mentre gli altri in \Bin\Folder_programma.
Il codice è commentato perchè altrimenti, come dicevo, il player resta settato: dovrebbe essere l'utente a decommentare una delle tre stringhe della sezione [Environment] e la stringa della sezione [WriteToIni].

[Environment]
;set a player for preview:
;eMULE_PLAYER=@ScriptDir@\X-VideoLAN.exe
;eMULE_PLAYER=$Bin$\MediaPlayerClassic\mplayerc.exe
;eMULE_PLAYER=$Bin$\MPlayer\MPUI.exe


[WriteToIni=$ExeDir$\config\preferences.ini]
;eMule|VideoPlayer=%eMULE_PLAYER%



[ Modificato lun 21 mag 2007 - 02:14 ]
Torna ad inizio pagina
Sito Web
tittoproject
lun 21 mag 2007 - 15:15

online
Utente registrato #821
Registrato il: mer 24 gen 2007 - 17:22
Messaggi: 592
"Danix" ha scritto ...
Solo che, come dicevo, rimane come impostazione fissa.
Al limite potrei creare una variabile eMULE_PLAYER da impostare nell'ini, ma richiederebbe sempre l'intervento dell'utente sul X-Mule.ini

Se solo si potesse utilizzare un "if" come nel php: se X-VideoLan è presente eMule lo utilizza, altrimenti si può impostare..

Beh, nei pack, con tutti i programmi già pronti, lo possiamo fare noi e l'utente non deve preoccuparsi di nulla.

Nel programma standalone, al momento la cosa più semplice è preparare le stringhe disabilitate e scrivere un mini howto su come farlo. In effetti, un mini howto dovremmo scriverlo per un bel po' di programmi...

Nel futuro mi faro' venire qualche altra idea, una cosa per volta
Torna ad inizio pagina
Danix
lun 21 mag 2007 - 17:58

online

Utente registrato #1
Registrato il: ven 29 dic 2006 - 05:38
Provenienza: Sassari
Messaggi: 12935
tittoproject ha scritto ...

Nel programma standalone, al momento la cosa più semplice è preparare le stringhe disabilitate e scrivere un mini howto su come farlo. In effetti, un mini howto dovremmo scriverlo per un bel po' di programmi...

Appunto

-Link-
Torna ad inizio pagina
Sito Web
tittoproject
mar 22 mag 2007 - 13:42

online
Utente registrato #821
Registrato il: mer 24 gen 2007 - 17:22
Messaggi: 592
Danix ha scritto ...

[/quote1179763033]
Appunto

-Link-

Danix, ma l'hai provato su eMule? Per quanto mi ricordo, questa opzione funziona SOLO su eMulePlus
Torna ad inizio pagina
Danix
mar 22 mag 2007 - 14:22

online

Utente registrato #1
Registrato il: ven 29 dic 2006 - 05:38
Provenienza: Sassari
Messaggi: 12935
In eMule normale in preference.ini era già previsto il campo
VideoPlayer=
Torna ad inizio pagina
Sito Web

Vai a pagina   <<      
Moderatori: Danix, Taf, Rcs, Energy, zandet2, ZioZione, Admin, LordJim60

Salta:     Torna ad inizio pagina

RSS discussione: rss 0.92 RSS discussione: rss 2.0 RSS discussione: RDF
Powered by e107 Forum System