Menù Principale

Cerca
Login
Registrati
Link sponsorizzati
Annunci
<< Discussione precedente | Discussione successiva >>   
X-Iron 9.0.600.0 [rev7] - chiavi di registro mancanti

Autore Messaggio
Danix
dom 13 feb 2011 - 00:49

online

Utente registrato #1
Registrato il: ven 29 dic 2006 - 05:38
Provenienza: Sassari
Messaggi: 12652

Ho modificato il launcher di X-Iron, adeguandolo a quello di X-Chromium.
In quest'ultima versione (ma anche nella precedente 8.0.555.1_rev6) sembra che l'unica chiave di registro da esportare sia:

HKEY_CURRENT_USER\Software\MozillaPlugins

e che, invece, tutte quelle incluse nel vecchio launcher non vengano più create:

HKEY_LOCAL_MACHINE\SOFTWARE\Classes\.htm\OpenWithList\iron.exe
HKEY_LOCAL_MACHINE\SOFTWARE\Classes\.html\OpenWithList\iron.exe
HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Applications\iron.exe
HKEY_CURRENT_USER\Software\Chromium


Qualcuno può confermare?




[ Modificato mer 16 feb 2011 - 16:27 ]
Torna ad inizio pagina
Sito Web
ZioZione
dom 13 feb 2011 - 12:37
online

Utente registrato #74
Registrato il: dom 21 gen 2007 - 11:31
Provenienza: Tradate (VA)
Messaggi: 3821
Ciao Danix,
confermo che le quattro chiavi di registro da te indicate, a me sembra che non vengano più create. Almeno, semplicemente eseguendo X-Iron, navigando un po' in giro e poi chiudendolo, non le trovo nel registro...
Cordialmente
ZioZione
Torna ad inizio pagina
Taf
dom 13 feb 2011 - 18:13

online

Utente registrato #251
Registrato il: lun 22 gen 2007 - 10:12
Provenienza: Buttrio (UD)
Messaggi: 3016
anch'io posso confermare il test dello Zio!
sto testando dal Netbook di casa con win XP home SP3
quindi... nuovo ini approvato
Torna ad inizio pagina
Bourne
lun 14 feb 2011 - 12:00

online
Utente registrato #4287
Registrato il: ven 20 apr 2007 - 16:55
Messaggi: 554
Danix ha scritto ...

Qualcuno può confermare?

Confermo
Torna ad inizio pagina
Bourne
lun 14 feb 2011 - 21:13

online
Utente registrato #4287
Registrato il: ven 20 apr 2007 - 16:55
Messaggi: 554
Come non detto.

Appena fatto l'aggiornamento al nuovissimo Iron 9.0.600.1 ed ecco 'sta schifosa chiave spuntar fuori:

----------------------------------
Keys added:1
----------------------------------
HKU\S-1-5-21-2159942938-2736604589-3455827649-1001\Software\Chromium

----------------------------------
Values added:1
----------------------------------
HKU\S-1-5-21-2159942938-2736604589-3455827649-1001\Software\Chromium\lastrun: "12942186910224109"


Come al solito con Win7Pro 32bit su account standard (non admin)
Torna ad inizio pagina
Taf
mar 15 feb 2011 - 09:43

online

Utente registrato #251
Registrato il: lun 22 gen 2007 - 10:12
Provenienza: Buttrio (UD)
Messaggi: 3016
Bourne ha scritto ...

Come non detto.

Appena fatto l'aggiornamento al nuovissimo Iron 9.0.600.1 ed ecco 'sta schifosa chiave spuntar fuori:

----------------------------------
Keys added:1
----------------------------------
HKU\S-1-5-21-2159942938-2736604589-3455827649-1001\Software\Chromium

----------------------------------
Values added:1
----------------------------------
HKU\S-1-5-21-2159942938-2736604589-3455827649-1001\Software\Chromium\lastrun: "12942186910224109"


Come al solito con Win7Pro 32bit su account standard (non admin)



appena rifatto il test su Win7Pro 64bit su account admin e UAC disabilitato

a me non compare nulla!

Bourne, sei sicuro di non aver fatto il test con X-Iron (o X-Chromium) attivo?

PS: riguardo al problema dell'apertura dei PDF, anailzzato in altro post ( -Link- ), posso dire che con X-Cromium i PDF si vedono senza problemi con il plugin messo nella opportuna cartella.
Ora, per poter dire che il problema sia nativo di Iron devo solo avere il tempo di provare con una versione "normalmente installata" diIiron.

[ Modificato mar 15 feb 2011 - 09:43 ]
Torna ad inizio pagina
Bourne
mar 15 feb 2011 - 11:10

online
Utente registrato #4287
Registrato il: ven 20 apr 2007 - 16:55
Messaggi: 554
Taf ha scritto ...

appena rifatto il test su Win7Pro 64bit su account admin e UAC disabilitato

a me non compare nulla!

Bourne, sei sicuro di non aver fatto il test con X-Iron (o X-Chromium) attivo?

Solitamente non mi incarto mai su queste cose ma cmq non si sa mai, quindi ho riprovato in tal modo:
1-Cancellata la chiave incriminata dal registro.
Quindi, con registro pulito ho lanciato il browser con il nuovo launcher, navigato su vari siti, visti siti con flash, ecc..
2-Chiuso browser, aspettato vari secondi perché si chiudesse tutto in maniera corretta ed infine controllato nel task manager che non fosse più presente alcun processo inerente iron e launcher.
3-A tal punto, eseguito poi il secondo snapshot e quindi la comparazione: eccalà, medesima chiave riapparsa nel registro...

Taf ha scritto ...
PS: riguardo al problema dell'apertura dei PDF, anailzzato in altro post ( -Link- ), posso dire che con X-Cromium i PDF si vedono senza problemi con il plugin messo nella opportuna cartella.
Ora, per poter dire che il problema sia nativo di Iron devo solo avere il tempo di provare con una versione "normalmente installata" diIiron.

Io sono ricorso ad uno userscript (che quindi occupa meno memoria, e la usa solo quando interviene, rispetto ad una equivalente estensione) che permette la veloce visualizzazione on-line dei formati pdf, doc, docx, xls, xlsx, ppt, pptx, rtf, odt, ods, odp, csv, sxw, sxc, sxi.

Cmq è interessante tu ci sia riuscito con una versione portabile di Chromium (perché fino a questo momento il plugin di vari visualizzatori pdf, adobe/foxit/xchangeviewer inclusi, richiedono la presenza del loro omonimo programma e registrazione nel sistema della dll che metta in comunicazione browser-visualizzatore), credo quindi dipenda da alcuni progressi fatti dal passaggio dei suoi sorgenti 9.x (usati dalla corrente versione di iron) a quelli attuali 11.x

Ciiiao

[ Modificato mar 15 feb 2011 - 11:10 ]
Torna ad inizio pagina
Taf
mar 15 feb 2011 - 12:47

online

Utente registrato #251
Registrato il: lun 22 gen 2007 - 10:12
Provenienza: Buttrio (UD)
Messaggi: 3016
Bourne ha scritto ...

Solitamente non mi incarto mai su queste cose ma cmq non si sa mai, quindi ho riprovato in tal modo:
1-Cancellata la chiave incriminata dal registro.
Quindi, con registro pulito ho lanciato il browser con il nuovo launcher, navigato su vari siti, visti siti con flash, ecc..
2-Chiuso browser, aspettato vari secondi perché si chiudesse tutto in maniera corretta ed infine controllato nel task manager che non fosse più presente alcun processo inerente iron e launcher.
3-A tal punto, eseguito poi il secondo snapshot e quindi la comparazione: eccalà, medesima chiave riapparsa nel registro...


Allora... evoluzione dei test: ... scoperto l'inghippo!
Mi sono scaricato l'ultimo IronPortable da qui: -Link-
mi sono accorto che la versione che abbiamo noi nel pacchetto X-Iron è la 9.0.600.1 (73000) mentre l'eseguibile presente in IronPortable è siglato 9.0.600.1 (74000)
sostituendo questo pacchetto in BIN di X-Iron anch'io mi ritrovo la famigerata chiave nel registro di sistema (basta solo aprire e chiudere X-Iron e già si presenta...)

Bourne ha scritto ...

Taf ha scritto ...
PS: riguardo al problema dell'apertura dei PDF, anailzzato in altro post ( -Link- ), posso dire che con X-Cromium i PDF si vedono senza problemi con il plugin messo nella opportuna cartella.
Ora, per poter dire che il problema sia nativo di Iron devo solo avere il tempo di provare con una versione "normalmente installata" diIiron.

Io sono ricorso ad uno userscript (che quindi occupa meno memoria, e la usa solo quando interviene, rispetto ad una equivalente estensione) che permette la veloce visualizzazione on-line dei formati pdf, doc, docx, xls, xlsx, ppt, pptx, rtf, odt, ods, odp, csv, sxw, sxc, sxi.


potresti essere più dettagliato su questo punto? Come hai impostato il tuo userscript?

Bourne ha scritto ...

Cmq è interessante tu ci sia riuscito con una versione portabile di Chromium (perché fino a questo momento il plugin di vari visualizzatori pdf, adobe/foxit/xchangeviewer inclusi, richiedono la presenza del loro omonimo programma e registrazione nel sistema della dll che metta in comunicazione browser-visualizzatore), credo quindi dipenda da alcuni progressi fatti dal passaggio dei suoi sorgenti 9.x (usati dalla corrente versione di iron) a quelli attuali 11.x
Ciiiao


anche qui ci sono novità:
1) X-chromium (in cui ho copiato il mio profilo utente di X-Iron = il plugin per i PDF NON FUNZIONA!!! (contrariamente a quanto affermato precedentemente... SIGH!)
2) Iron correttamente installato sul sistema ed utilizzato con il mio profilo di X-Iron = il plugin per i PDF funziona
3) IronPortable appena scaricato e testato con il profilo del mio x-iron = il plugin per i PDF funziona
4) X-Iron con cartella di programma presente in BIN aggiornata all'ultima versione [9.0.600.1 (74000)] = il plugin per i PDF NON FUNZIONA!!!

....ora però resta da capire il perché!!


[ Modificato mar 15 feb 2011 - 12:55 ]
Torna ad inizio pagina
Bourne
mar 15 feb 2011 - 19:47

online
Utente registrato #4287
Registrato il: ven 20 apr 2007 - 16:55
Messaggi: 554
Taf ha scritto ...

mi sono accorto che la versione che abbiamo noi nel pacchetto X-Iron è la 9.0.600.1 (73000) mentre l'eseguibile presente in IronPortable è siglato 9.0.600.1 (74000)

Urca che storia
Taf ha scritto ...

potresti essere più dettagliato su questo punto? Come hai impostato il tuo userscript?

-Link-

Taf ha scritto ...

anche qui ci sono novità:
1) X-chromium (in cui ho copiato il mio profilo utente di X-Iron = il plugin per i PDF NON FUNZIONA!!! (contrariamente a quanto affermato precedentemente... SIGH!)
2) Iron correttamente installato sul sistema ed utilizzato con il mio profilo di X-Iron = il plugin per i PDF funziona
3) IronPortable appena scaricato e testato con il profilo del mio x-iron = il plugin per i PDF funziona
4) X-Iron con cartella di programma presente in BIN aggiornata all'ultima versione [9.0.600.1 (74000)] = il plugin per i PDF NON FUNZIONA!!!

Questo è veramente moolto interessante.
Torna ad inizio pagina
Danix
mer 16 feb 2011 - 01:14

online

Utente registrato #1
Registrato il: ven 29 dic 2006 - 05:38
Provenienza: Sassari
Messaggi: 12652
La nuova versione 9.0.600.1 crea la chiave HKEY_CURRENT_USER\Software\Chromium. Problema risolto con X-Iron 9.0.600.1 [rev8]
Torna ad inizio pagina
Sito Web

Moderatori: Danix, Taf, Rcs, Energy, zandet2, ZioZione, Admin, LordJim60

Salta:     Torna ad inizio pagina

RSS discussione: rss 0.92 RSS discussione: rss 2.0 RSS discussione: RDF
Powered by e107 Forum System