Menù Principale

Cerca
Login
Registrati
Link sponsorizzati
Annunci
<< Discussione precedente | Discussione successiva >>   
[Released] X-WinFF 1.3.2_rev4

Autore Messaggio
Danix
ven 25 feb 2011 - 00:52

online

Utente registrato #1
Registrato il: ven 29 dic 2006 - 05:38
Provenienza: Sassari
Messaggi: 12638

La nuova versione 1.3.2 di WinFF non si avvia in Italiano (al contrario della 1.3.1 che evidentemente riconosceva la lingua di sistema). Inoltre non c'è modo di cambiare lingua dall'interfaccia! Qualcuno potrebbe scaricarle entrambe e verificare se riscontra gli stessi problemi? Tenendo conto che X-WinFF è segnalato sul sito ufficiale del programma, forse varrebbe la pena spenderci due minuti.

Test richiesto/Test needed:
X-WinFF_1.3.2_rev4_test1 (9,72 MB)


Rilasciato/Released:
X-WinFF_1.3.2_rev4

Nota: nell'attesa che l'autore si accorga del problema, o che qualcuno lo segnali nel forum ufficiale, ho aggiunto i file della lingua di eagleman e ho rilasciato la nuova versione.

[ Modificato lun 28 feb 2011 - 20:07 ]
Torna ad inizio pagina
Sito Web
eagleman
ven 25 feb 2011 - 10:27
online
Utente registrato #9
Registrato il: sab 20 gen 2007 - 21:36
Provenienza: Veglie
Messaggi: 431
Confermo il test.
La 1.3.1 si avvia in italiano, la 1.3.2 no, anche se la traduzione necessita di un aggiornamento. Ho visto che ci sono delle righe modificate e delle righe nuove nel file PO, ma anche questo non dovrebbe provocare il problema visto che quelle già presenti dovrebbero essere visualizzate e invece manco quelle.
Torna ad inizio pagina
eagleman
ven 25 feb 2011 - 11:01
online
Utente registrato #9
Registrato il: sab 20 gen 2007 - 21:36
Provenienza: Veglie
Messaggi: 431
Conferma ufficiale.
Il problema del non avvio in italiano del programma dipende dalla traduzione che va aggiornata.
Inserite il file PO presente in questo file nella cartella Bin/Winff/languages e il programma si avvierà di nuovo in italiano.
winff132ita.zip
Torna ad inizio pagina
zandet2
ven 25 feb 2011 - 11:26

online

Utente registrato #3184
Registrato il: mar 06 mar 2007 - 11:52
Provenienza: Busto Arsizio
Messaggi: 3282
@eagleman,
ho effettuato qualche test, e in realtà è il file ".mo" che va aggiunto, con il solo file ".po" continua a partire in inglese.

Comunque dal changelog:
"Much better translations, uses Lazarus' new translatiion system"

Mi sa che l'autore non ha testato le altre lingue, cosa tra parentesi impossibile visto che non c'è modo di impostare la lingua da configurazione. Chissà se le altre lingue hanno lo stesso problema...
Torna ad inizio pagina
Taf
ven 25 feb 2011 - 11:51

online

Utente registrato #251
Registrato il: lun 22 gen 2007 - 10:12
Provenienza: Buttrio (UD)
Messaggi: 2992
confermo test di eagleman.

NOTA:
Resta il fatto che il file di traduzione nuovo (sopra linkato) non è comunque completo.
Ha delle voci che rimangono in inglese

---EDIT---
...e pure le considerazioni di Zandet2! (che ha postato mentre scrivevo)

[ Modificato ven 25 feb 2011 - 11:53 ]
Torna ad inizio pagina
eagleman
ven 25 feb 2011 - 12:03
online
Utente registrato #9
Registrato il: sab 20 gen 2007 - 21:36
Provenienza: Veglie
Messaggi: 431
Taf ha scritto ...

confermo test di eagleman.

NOTA:
Resta il fatto che il file di traduzione nuovo (sopra linkato) non è comunque completo.
Ha delle voci che rimangono in inglese

---EDIT---
...e pure le considerazioni di Zandet2! (che ha postato mentre scrivevo)


Per le voci che rimangono in inglese ho cercato di fare il possibile, ma ci sono alcune stringhe particolari che anche volendo rimangono così come sono.
Se poi mi dici quali sono le voci che rimagono in inglese vedo di sistemarle.
Torna ad inizio pagina

Moderatori: Danix, Taf, Rcs, Energy, zandet2, ZioZione, Admin, LordJim60

Salta:     Torna ad inizio pagina

RSS discussione: rss 0.92 RSS discussione: rss 2.0 RSS discussione: RDF
Powered by e107 Forum System