Main menu

Search
Login
Signup
Sponsored Links
<< Previous thread | Next thread >>   
X-VideoLAN non memorizza le skin

Go to page       >>  
Author Post
Microchip
Sun 02 Dec 2007 - 13:58

online
Registered Member #4763
Joined: Sat 19 May 2007 - 18:48
Posts: 63

La nuova versione ha qualche problemuccio...
sia con Windows XP che con Vista, dopo il lancio di x-videolan, salta fuori che vlc.exe ha smesso di funzionare...

Ho fatto delle prove e, secondo me, è qualcosa che ha a che fare con le skin, come se non le riuscissse a caricare.
Io ne avevo una e quindi non partiva.

Ho fatto partire x-videolan senza skin e funziona, ma se metto la skin, appena la seleziono dal programma per impostarla... BOOM!


magari è la stessa cosa di cui parla elleperdue qui

[ Edited Sun 02 Dec 2007 - 20:40 ]
Back to top
elleperdue
Sun 02 Dec 2007 - 14:23
online
Registered Member #5657
Joined: Wed 08 Aug 2007 - 15:59
Posts: 25
Si, effettivamente avevo una skin diversa da quella di default, e commentando la corrispondente linea nel file vlc.config, ora VideoLAN parte anche nella versione X.
Ciao

PS. mi scuso per aver segnalato questo problema nel topic dedicato agli aggiornamenti, come fatto notare da Danix
Back to top
Danix
Sun 02 Dec 2007 - 14:59

online

Registered Member #1
Joined: Fri 29 Dec 2006 - 05:38
Location: Sassari
Posts: 12858
Puoi zippare e postare il tuo file vlc.config, per favore?
Back to top
Website
elleperdue
Sun 02 Dec 2007 - 17:52
online
Registered Member #5657
Joined: Wed 08 Aug 2007 - 15:59
Posts: 25
Ciao,
in allegato il file di configurazione.
La linea che ho commentato è la 292 : #intf=skins2
Mi sono accorto che la skin personalizzata viene salvata con il pathname assoluto (linea 1440); se questo non è un problema per la mia installazione (su HD) potrebbe inficiare la portabilità, o no?

Grazie
vlc.7z
Back to top
Danix
Sun 02 Dec 2007 - 18:23

online

Registered Member #1
Joined: Fri 29 Dec 2006 - 05:38
Location: Sassari
Posts: 12858
Devi vedere se spostando X-VideoLan su un'altra partizione quel percorso viene automaticamente aggiornato.
Hai provato?

P.S. io non riesco a cambiare skin nè lanciando vlc.exe originale, nè lanciando X-VideoLAN.exe
Ho solo skin2 nella barra in alto. Ne hai scaricate altre?

[ Edited Sun 02 Dec 2007 - 18:25 ]
Back to top
Website
Danix
Sun 02 Dec 2007 - 18:28

online

Registered Member #1
Joined: Fri 29 Dec 2006 - 05:38
Location: Sassari
Posts: 12858
Danix wrote ...

Devi vedere se spostando X-VideoLan su un'altra partizione quel percorso viene automaticamente aggiornato.
Hai provato?

Ho appena provato io, non viene aggiornato.
Anzichè decommentare, aggiungi questo codice a X-VideoLAN.ini e vedi se tutto funziona regolarmente

[StringReplace=%VLC_HOME%\vlc.config]
skins2-last|\skins==$ExeDir$


Scrivimi tutti i path assoluti che non vengono aggiornati, oltre a quello.
Ad esempio, cos'hai in skins2-config= ?

[ Edited Sun 02 Dec 2007 - 18:34 ]
Back to top
Website
elleperdue
Sun 02 Dec 2007 - 19:27
online
Registered Member #5657
Joined: Wed 08 Aug 2007 - 15:59
Posts: 25
Ho scaricato altre skin, ma per attivarle bisogna passare da skin2 e poi scegliere quella desiderata (ad esempio io usavo ASkin.vlt).
Il problema rimane, ovvero X-VideoLAN va in crash quando si cerca di cambiare interfaccia (Impostazioni -> Cambia interfaccia -> Skins 2.
Ho anche provato a resettare il file di configurazione, ma non è cambiato nulla. Ovviamente ora il file non ha alcuna skin particolare configurata e quindi non ha path di riferimento, essendo quello di default, eppure continua ad andare in crash.
In skins2-config ci sono parametri di visualizzazione della finestra (almeno così mi sembrano).
Ho provato a scaricare la versione "non portabile", scompattarla con Universal Extractor ma non riesco a farla assolutamente partire (devo per forza installarla?).

Proverò a vedere se vengono segnalati problemi analoghi sul forum di videolan ....

Grazie
Back to top
Danix
Sun 02 Dec 2007 - 19:41

online

Registered Member #1
Joined: Fri 29 Dec 2006 - 05:38
Location: Sassari
Posts: 12858
Si è vero va in crash, ma a prescindere dal fatto che sia o meno avviato da X-VideoLAN.exe
Anche avviandolo da vlc.exe, il problema rimane. Confermi?

Inoltre ho notato che anche la versione precedente (0.8.6c) non permette di impostare le skin, sempre a prescidere che sia portatile o meno...

[ Edited Sun 02 Dec 2007 - 19:56 ]
Back to top
Website
elleperdue
Sun 02 Dec 2007 - 20:01
online
Registered Member #5657
Joined: Wed 08 Aug 2007 - 15:59
Posts: 25
Il problema si presenta anche lanciando vlc.exe in Bin di winPenPack, ma invece è ok se eseguito il programma installato.

Mi sono accorto che la versione installata crea C:\Documents and Settings\<username>\Dati applicazioni\vlc con all'interno un file vlcrc ed una cartella cache. Lanciando la versione X non vedo questi file da nessuna parte, magari non è rilevante ... oppure è voluto....



Back to top
Danix
Sun 02 Dec 2007 - 20:06

online

Registered Member #1
Joined: Fri 29 Dec 2006 - 05:38
Location: Sassari
Posts: 12858
Quei file e cartelle vengono creati comunque anche avviando vlc.exe da Bin, non è necessario che il programma sia installato.
Che significa è ok nella versione installata?
Vengono memorizzate le skin? In questo caso, puoi scrivere esattamente i passaggi per far memorizzare una skin nella versione installata?


[ Edited Sun 02 Dec 2007 - 20:07 ]
Back to top
Website

Go to page       >>  
Moderators: Danix, Taf, Rcs, Energy, zandet2, ZioZione, Admin, LordJim60

Jump:     Back to top

Syndicate this thread: rss 0.92 Syndicate this thread: rss 2.0 Syndicate this thread: RDF
Powered by e107 Forum System