Main menu

Search
Login
Signup
Links
<< Previous thread | Next thread >>   
X-Scribus launcher 1.3.4 (development)

Go to page       >>  
Author Post
Danix
Thu 31 May 2007 - 01:35

online

Registered Member #1
Joined: Fri 29 Dec 2006 - 05:38
Location: Sassari
Posts: 12926

Il Core della versione 1.3.4 di Scribus è cambiato.
La variabile %HOME% sembra che non sia più letta come nelle versioni precedenti.

Non avendo trovato riferimenti precisi sulla variabile, forse personalizzata, ho dovuto "arrangiarmi" per renderlo comunque portatile. Non è stato facile perchè Scribus, stranamente, utilizza le barre diritte, anzichè rovesciate, nei percorsi. Pertanto alcune variabili di X-Launcher non vengono lette. Per fortuna c'erano quelle di Autoit.

Il vantaggio è però che viene utilizzata la cartella "Documents" (in perfetto stile a cartelle separate di winPenPack) per salvare i documenti.
Sono inoltre riuscito a far si che il programma legga i "documenti recenti " anche se la lettera del drive cambia.

Gradirei che:

  • qualcuno lo testasse per darmi conferma che funziona anche se, ormai, è già nel winPenPack Flash 512 v2.8.3.
  • qualcuno potesse darmi qualche informazione sulla variabile Home di Scribus


Grazie.

Ini code:

[Setup]
AppName=Scribus

[FileToRun]
PathToExe=$Bin$\$AppName$\$AppName$.exe

[Environment]
SCRIBUS_HOME=$Home$\$AppName$
PATH=$Lib$\Ghostscript

[Functions]
DirCreate=%SCRIBUS_HOME%
DirMove=%SCRIBUS_HOME%|@AppDataDir@\$AppName$|o
DirCreate=$Doc$\$AppName$

[RunAfter]
DirMove=@AppDataDir@\$AppName$|%SCRIBUS_HOME%|o

[StringReplace=@AppDataDir@\$AppName$\scribus134.rc]
DOC|SHOWLAYERM=="$Doc$\$AppName$" 
RECENT NAME|/Scribus/=="$Doc$

[Options]
DeleteTemp=true
MultipleIstances=true
RunWait=true
ShowSplash=false
WriteLog=false

[SplashScreen]
Image=
Title=
TimeOut=1000



[ Edited Sun 22 Jun 2008 - 18:16 ]
Back to top
Website
Taf
Mon 04 Jun 2007 - 19:51

online

Registered Member #251
Joined: Mon 22 Jan 2007 - 10:12
Location: Buttrio (UD)
Posts: 3332
oggi ho provato il nuovo X-Scribus....
Errore!
vedi screen allegato...
io non ci ho capito nulla!


[ Edited Tue 05 Jun 2007 - 11:29 ]
Back to top
Danix
Mon 04 Jun 2007 - 20:05

online

Registered Member #1
Joined: Fri 29 Dec 2006 - 05:38
Location: Sassari
Posts: 12926
Scusa, ma hai scaricato X-Scribus dalla sezione download? O è in un pack? Lo hai aggiunto? che ini hai usato?


P.S.: le immagini è meglio se le carichi come allegato, oppure scegli immagini piccole....

[ Edited Mon 04 Jun 2007 - 20:07 ]
Back to top
Website
Taf
Tue 05 Jun 2007 - 11:27

online

Registered Member #251
Joined: Mon 22 Jan 2007 - 10:12
Location: Buttrio (UD)
Posts: 3332
Ho provato sia con il programma presente nel Pack 512 che con il programma "standalone"scaricato dal sito.
gli ini utilizzati sono quelli presenti nelle 2 versuioni (pack512 e x-scribus "solo").

Non ho modificato nulla!

PS: scusa per le immagini.... provvedo subito!
Back to top
Danix
Tue 05 Jun 2007 - 11:32

online

Registered Member #1
Joined: Fri 29 Dec 2006 - 05:38
Location: Sassari
Posts: 12926
Ma allora mi dici che è quel percorso??

C:\U\_wpp\winPenPack\XDrive\X-Scribus.exe??

Quando X-Scribus.exe in XDrive non è presente?

Non hai modificato niente? E' presente in XDrive X-Launcher.cfg?

[ Edited Tue 05 Jun 2007 - 11:35 ]
Back to top
Website
elleperdue
Wed 08 Aug 2007 - 16:25
online
Registered Member #5657
Joined: Wed 08 Aug 2007 - 15:59
Posts: 25
Un saluto a tutti quanti da un novellino del forum, e complimenti per il lavoro che svolgete con tanto impegno. Approfitto di questo thread, sia pure ormai fermo da due mesi, per segnalarvi che anche nella wPP 3.0 persiste il problema con il launcher di X-Scribus, cosa prevedibile non avendo avuto ulteriori rilasci dalla 2.8.3. Confermo quanto detto da Taf, ovvero il problema si presenta sia con il package completo, quindi X-Scribus.exe e relativo ini, sia con il solo ini file come da package 3.0 1G scaricato oggi. Inoltre ho verificato che non viene creato il direttorio User/Scribus mentre viene creato Documents/Scribus e questo mi sembra strano essendo presenti in X-Scribus.ini le corrispondenti funzioni DirCreate.
Come ultima cosa, che spero possa aiutare qualcuno nel circoscrivere il problema, faccio presente che pur con la flag WriteLog=true non trovo traccia nel file di log dell'istruzione

IniWrite($Log, 'FileToRun', 'StringToExe', $StringToExe)

che dovrebbe precedere l'operazione di Run (almeno guardando il codice sorgente di x-launcher)

Grazie
Back to top
Danix
Wed 08 Aug 2007 - 17:18

online

Registered Member #1
Joined: Fri 29 Dec 2006 - 05:38
Location: Sassari
Posts: 12926
Benvenuto su winPenPack elleperdue
Quindi praticamente X-Scribus non si avvia?
Back to top
Website
MAXPC72
Wed 08 Aug 2007 - 17:33
online
Registered Member #4454
Joined: Mon 30 Apr 2007 - 16:35
Posts: 88
a me si avvia, ho scaricato stamattina il pack 1GB e va'.
viene creato sia il direttorio User/Scribus che Documents/Scribus

Back to top
Danix
Wed 08 Aug 2007 - 17:45

online

Registered Member #1
Joined: Fri 29 Dec 2006 - 05:38
Location: Sassari
Posts: 12926
Anche a me si avvia normalmente.
Ma ho appena provato su un sistema pulito: non si avvia!
(il launcher non c'entra, non si avvia neanche lanciando \Bin\Scribus\Scribus.exe)
Evidentemente il programma richiede qualche file al di fuori della propria directory.
Magari una .dll in system32...devo indagare meglio..

Inoltre, sul sito danno ancora la 1.3.3.9 come stable....non vorrei dipendesse da questo...
E credo di aver fatto una scemenza ad inserire la 1.3.4-devel

Quindi, ora cerco di risolvere il problema per la 1.3.4 e poi rilascio un fix con la 1.3.3.9 per i packs.

[ Edited Wed 08 Aug 2007 - 17:57 ]
Back to top
Website
Danix
Wed 08 Aug 2007 - 18:48

online

Registered Member #1
Joined: Fri 29 Dec 2006 - 05:38
Location: Sassari
Posts: 12926
Aggiornamento: non son riuscito a risolvere.
Non capisco cosa impedisca l'avvio del programma su un sistema nel quale non è mai stato installato. Ho monitorato con totaluninstall, ma con scarso successo.
Se magari qualcuno può fare qualche prova...

In compenso il launcher per la 1.3.4 non mi piace molto come forma.
E' meglio utilizzare questo (ma il risultato non cambia per ciò che riguarda l'avvio, infatti non dipende dal launcher):

[Setup]
AppName=Scribus

[FileToRun]
PathToExe=$Bin$\$AppName$\$AppName$.exe

[Environment]
PATH=$Lib$\Ghostscript
DocPath=$Doc$\$AppName$

[Functions]
DirCopy=$Home$\$AppName$|@AppDataDir@\$AppName$|o
DirCreate=%DocPath%

[RunAfter]
DirCopy=@AppDataDir@\$AppName$|$Home$\$AppName$|o
DirRemove=@AppDataDir@\$AppName$

[StringReplace=@AppDataDir@\$AppName$\scribus134.rc]
DOC|SHOWLAYERM=="%DocPath%" 
RECENT NAME|/Scribus/=="$Doc$

[Options]
DeleteTemp=true
MultipleIstances=true
RunWait=true
ShowSplash=false
WriteLog=false

[SplashScreen]
Image=
Title=
TimeOut=1000


Back to top
Website

Go to page       >>  
Moderators: Danix, Taf, Rcs, Energy, zandet2, ZioZione, Admin, LordJim60

Jump:     Back to top

Syndicate this thread: rss 0.92 Syndicate this thread: rss 2.0 Syndicate this thread: RDF
Powered by e107 Forum System