Main menu

Search
Login
Signup
Sponsored Links
<< Previous thread | Next thread >>   
Bug in X-Gimp 2.8.0 [rev19]

Go to page       >>  
Author Post
dropper
Wed 09 May 2012 - 20:38

online
Registered Member #39636
Joined: Tue 15 Feb 2011 - 23:47
Posts: 162

After the run of X-Gimp 2.8.0 [rev19] I get the following error message: http://dl.dropbox.com/u/3488658/Gimp_BUG.png
Back to top
robby
Wed 09 May 2012 - 20:49

online
Registered Member #53
Joined: Sun 21 Jan 2007 - 10:10
Location: Novi Ligure
Posts: 28
Anche a me appare lo stesso messaggio di errore, se utilizzo lo strumento per aggiungere testo non riesce a caricare la lista dei font presenti sul computer... probabilmente è una conseguenza del medesimo bug. Provato con W7 Professional e anche su XP professional, entrambi aggiornati.
Saluti
Back to top
Danix
Thu 10 May 2012 - 01:27

online

Registered Member #1
Joined: Fri 29 Dec 2006 - 05:38
Location: Sassari
Posts: 12621
@dropper and @robby, please try X-Gimp 2.8.0 [rev20].
Back to top
Website
dropper
Thu 10 May 2012 - 01:39

online
Registered Member #39636
Joined: Tue 15 Feb 2011 - 23:47
Posts: 162
This link doesn't work
Back to top
Danix
Thu 10 May 2012 - 01:48

online

Registered Member #1
Joined: Fri 29 Dec 2006 - 05:38
Location: Sassari
Posts: 12621
Upload in progress..
Try again in a few minutes.
Back to top
Website
dropper
Thu 10 May 2012 - 10:03

online
Registered Member #39636
Joined: Tue 15 Feb 2011 - 23:47
Posts: 162
I have tested the new version X-Gimp 2.8.0 [rev20]. And once again a dialog window with the error message occurs, which I have described with the screenshot in my original post.
Back to top
Danix
Thu 10 May 2012 - 10:07

online

Registered Member #1
Joined: Fri 29 Dec 2006 - 05:38
Location: Sassari
Posts: 12621
Have you tried a fresh install or an upgrade?
Back to top
Website
dropper
Thu 10 May 2012 - 10:27

online
Registered Member #39636
Joined: Tue 15 Feb 2011 - 23:47
Posts: 162
Obviously this error message occurs only in conjunction with an upgrade. Now I have performed a fresh installation and all works fine

Therefore the upgrade feature is defect. Also I doesn't get the new splash screen in case of an upgrade.

[ Edited Thu 10 May 2012 - 10:32 ]
Back to top
Danix
Thu 10 May 2012 - 14:26

online

Registered Member #1
Joined: Fri 29 Dec 2006 - 05:38
Location: Sassari
Posts: 12621
dropper wrote ...

Therefore the upgrade feature is defect.

It seems the problem concerns only the file X-Gimp_2.8.0_rev20\Bin\Gimp\lib\gimp\2.0\plug-ins\file-pdf.exe
I don't know what causes the error and how to solve it. Perhaps a web search could help us.

dropper wrote ...

Also I doesn't get the new splash screen in case of an upgrade.

Delete the gimp-splash.png image from X-Gimp_2.8.0_rev20\User\Gimp directory
Back to top
Website
zandet2
Thu 10 May 2012 - 21:25

online

Registered Member #3184
Joined: Tue 06 Mar 2007 - 11:52
Location: Busto Arsizio
Posts: 3275
Forse ho inteso il problema:
ci sono dei plugin delle versioni precedenti incompatibili con la nuova versione di Gimp.

Se eseguo x-gimp da una installazione "pulita" si avvia senza nessun problema, se invece aggiorno una versione preesistente all'avvio mi si verificano i seguenti errori:

libgimpui-2.0-0.dll / errore gimp_drawable_get_thumbnail :
Winicon.exe
jpeg.exe

libgimpui-2.0-0.dll / errore gimp_layer_new_from_pixbuf :
svg.exe
poppler.exe
file-pdf.exe

I plugin risiedono in Bin\Gimp\lib\gimp\2.0\plug-ins; nella nuova versione sono assenti, me li ritrovo ereditati da release precendenti (quali? boh).

Una cosa che si potrebbe fare è inserire una sezione FirstRun che elimina questi plugin al primo avvio, insieme al vecchio splash screen:
[FirstRunOperations]
FileMove=$Home$\$AppName$\gimp-splash.png|$Home$\$AppName$\gimp-splash.png.$AppVer$|o
FileMove=$Bin$\$AppName$\lib\gimp\2.0\plug-ins\winicon.exe|$Bin$\$AppName$\lib\gimp\2.0\plug-ins\winicon.exe.$AppVer$|o
FileMove=$Bin$\$AppName$\lib\gimp\2.0\plug-ins\jpeg.exe|$Bin$\$AppName$\lib\gimp\2.0\plug-ins\jpeg.exe.$AppVer$|o
FileMove=$Bin$\$AppName$\lib\gimp\2.0\plug-ins\svg.exe|$Bin$\$AppName$\lib\gimp\2.0\plug-ins\svg.exe.$AppVer$|o
FileMove=$Bin$\$AppName$\lib\gimp\2.0\plug-ins\poppler.exe|$Bin$\$AppName$\lib\gimp\2.0\plug-ins\poppler.exe.$AppVer$|o
FileMove=$Bin$\$AppName$\lib\gimp\2.0\plug-ins\file-pdf.exe|$Bin$\$AppName$\lib\gimp\2.0\plug-ins\file-pdf.exe.$AppVer$|o


Ciao!
Back to top

Go to page       >>  
Moderators: Danix, Taf, Rcs, Energy, zandet2, ZioZione, Admin, LordJim60

Jump:     Back to top

Syndicate this thread: rss 0.92 Syndicate this thread: rss 2.0 Syndicate this thread: RDF
Powered by e107 Forum System