Menù Principale

Cerca
Login
Registrati
Link sponsorizzati
<< Discussione precedente | Discussione successiva >>   
[Initial release] X-Iron_4.0.280.0_rev3

Vai a pagina   <<        >>  
Autore Messaggio
Danix
lun 17 ago 2009 - 02:42

online

Utente registrato #1
Registrato il: ven 29 dic 2006 - 05:38
Provenienza: Sassari
Messaggi: 12823
UncleDan ha scritto ...

Ora devo solo capire come aggiungere a Preferences:
   "browser": {
      "check_default_browser": false
   },

per evitare la noiosissima domanda se lo vuoi come browser predefinito quando si crea il profilo.

Buona idea, non ci avevo pensato.
Prendi spunto dal nuovo x-default_prefs di Chromium -Link-

E aggiungi:

<<RE>>|0=("check_default_browser": ).+<<RE>>$1false

Sotto:

[StringRegExpReplace=%Profile%\Default\Preferences]

Torna ad inizio pagina
Sito Web
UncleDan
lun 17 ago 2009 - 09:54

online
Utente registrato #4764
Registrato il: sab 19 mag 2007 - 19:39
Provenienza: Bologna, Italy
Messaggi: 125
Ci avevo già pensato, ma non funziona in quanto il parametro non esiste finché non rispondi alla domanda, quindi il replace non trova nulla da sostituire. D'altro canto se usi un WriteToPref ed è già stato settato te lo trovi doppio (è solo una congettura, non sono riuscito a farglielo scrivere). Comunque ora sono abbastanza soddisfatto del risultato.

EDIT: vedo ora che l'hai applicato a Chromium, ora provo il tuo

[ Modificato lun 17 ago 2009 - 10:01 ]
Torna ad inizio pagina
Sito Web
UncleDan
lun 17 ago 2009 - 12:23

online
Utente registrato #4764
Registrato il: sab 19 mag 2007 - 19:39
Provenienza: Bologna, Italy
Messaggi: 125
Nuova versione: -Link-

Come puoi vedere ho cambiato la revision, perché anche se è "fortemente ispirato" a X-Chromium.ini, per X-Iron.ini in definitiva è una rev1.

Ho aggiunto la riga per il default browser e (anche se non mi spiego il perché) funziona perfettamente con il launcher di X-Chromium.

Ho anche fatto i compiti ricompilando il launcher con l'icona giusta, ma con il mio (di cui allego comunque sorgenti ed eseguibile al pacchetto) ricompilato dai sorgenti di X-Launcher l'ini non funzia, con il launcher di X-Chromium sì. Allora ci sono tre possibilità:

  • Io sono completamente fuso
  • Nel launcher di X-Chromium ci sono delle personalizzazioni che non avendo i sorgenti non vedo
  • Tutte e due le precedenti


Al di là delle battute grazie per la pazienza dimostrata.

[ Modificato lun 17 ago 2009 - 13:38 ]
Torna ad inizio pagina
Sito Web
UncleDan
mar 25 ago 2009 - 18:23

online
Utente registrato #4764
Registrato il: sab 19 mag 2007 - 19:39
Provenienza: Bologna, Italy
Messaggi: 125
Non sto a postare una nuova versione per questo, ma penso che la sezione Environment sia meglio così:

[Environment]
Profile=$Home$\$AppName$\Profiles
Registry=$Home$\$AppName$\Registry
DownloadDir=$Download$


Praticamente ho aggiunto \Profiles a %PROFILE%

Sto ancora facendo delle prove, ma mi è capitato a volte che non mi riproponesse wPP come home (torna a posto se cancelli il profilo, ma non è il massimo...)

Se mi data i sorgenti di X-Chromium launcher sarei curioso di provare a ricompilarlo perché al momento con il launcher compilato da me non va, mentre funzia con X-Chromium.exe (rinominato in X-Iron.exe)

Thanks in advance.
Torna ad inizio pagina
Sito Web
Taf
mer 26 ago 2009 - 09:16

online

Utente registrato #251
Registrato il: lun 22 gen 2007 - 10:12
Provenienza: Buttrio (UD)
Messaggi: 3192
Ciao UncleDan,
intanto grazie per i test che stai svolgendo.
appena tornano in zona i "guru" (Danix, Zandet2, ZioZione) vedrai che ti accontenteranno con i sorgenti.. (io non li ho a disposizione in questo momento).

in questo periodo "post ferie" ci vuole un po' più di pazienza del solito

Comunque, sarebbe meglio indagare più approfonditamente del perché X-Iron perde la home di WPP e si ripristina se cancelli il profilo. Non è ammissibile un simile comportamento... (sei riuscito ad associare una data situazione a questo comportamento? (es. Spostamento del programma su altro PC, Utilizzo su Vista, Utilizzo su XP etc. etc). ?

Grazie in anticipo per ogni tuo eventuale feedback

[ Modificato mer 26 ago 2009 - 09:17 ]
Torna ad inizio pagina
Niconweb
mer 26 ago 2009 - 09:39

online
Utente registrato #9306
Registrato il: ven 29 feb 2008 - 18:16
Messaggi: 11
Ciao a tutti,
vorrei dire che anche Chromium presenta il problema del non mantenimento della pagina iniziale da quando è stata fatta l'ultima revisione del file .ini. Ed oltre a ciò, non mantiene il pulsante della pagina iniziale e la barra dei preferiti ("Mostra sempre la barra dei preferiti").
A voi succede?
Grazie
Torna ad inizio pagina
UncleDan
mer 26 ago 2009 - 10:16

online
Utente registrato #4764
Registrato il: sab 19 mag 2007 - 19:39
Provenienza: Bologna, Italy
Messaggi: 125
Credevo di averlo associato alla pulizia completa (cache+cookie+pass.salvate,ecc), ma il post di Niconweb pur riguardando Chromium mi ha fatto riflettere sul fatto che nell'ini è stata aggiunta la riga

<<RE>>|0=("check_default_browser": ).+<<RE>>$1false

(confesso, è stata una mia idea che poi Danix ha applicato a Chromium) perché al primo avvio non chiedesse se impostarlo come browser di default. Appena ho un attimo la quoto e vedo se é lì il problema: anche voi dovrete avere un po' di pazienza...

EDIT: lavoro su diversi PC ma tutti XP PRO SP3

[ Modificato mer 26 ago 2009 - 10:18 ]
Torna ad inizio pagina
Sito Web
Danix
ven 28 ago 2009 - 13:07

online

Utente registrato #1
Registrato il: ven 29 dic 2006 - 05:38
Provenienza: Sassari
Messaggi: 12823
UncleDan ha scritto ...

Non sto a postare una nuova versione per questo, ma penso che la sezione Environment sia meglio così:

[Environment]
Profile=$Home$\$AppName$\Profiles
Registry=$Home$\$AppName$\Registry
DownloadDir=$Download$


Praticamente ho aggiunto \Profiles a %PROFILE%

Secondo me va meglio la struttura precedente dove la cartella "Registry" fa parte delle altre cartelle del profilo.

UncleDan ha scritto ...

Sto ancora facendo delle prove, ma mi è capitato a volte che non mi riproponesse wPP come home (torna a posto se cancelli il profilo, ma non è il massimo...)

Forse è il caso di NON preimpostare la home di winPenPack perchè in quel modo non è possibile impostare altre pagine con l'opzione "Apri le seguenti pagine".

================================
vedi X-Chromium 3.0.190.0 [rev7] -Link-
================================

UncleDan ha scritto ...

Se mi data i sorgenti di X-Chromium launcher sarei curioso di provare a ricompilarlo perché al momento con il launcher compilato da me non va, mentre funzia con X-Chromium.exe (rinominato in X-Iron.exe)

Tutto il codice di winPenPack è su Subversion -Link-

Niconweb ha scritto ...

Ciao a tutti,
vorrei dire che anche Chromium presenta il problema del non mantenimento della pagina iniziale da quando è stata fatta l'ultima revisione del file .ini.

Il problema del non mantenimento di una pagina iniziale diversa da quella di winPenPack?


Niconweb ha scritto ...

Ed oltre a ciò, non mantiene il pulsante della pagina iniziale e la barra dei preferiti ("Mostra sempre la barra dei preferiti").

Il pulsante della pagina iniziale non lo trovo.


[ Modificato ven 28 ago 2009 - 13:37 ]
Torna ad inizio pagina
Sito Web
Niconweb
ven 28 ago 2009 - 14:23

online
Utente registrato #9306
Registrato il: ven 29 feb 2008 - 18:16
Messaggi: 11
Il pulsante della pagina iniziale non è impostato di default, occorre andare in opzioni --> impostazioni di base e spuntare "Mostra pulsante pagina iniziale nella barra degli strumenti"
Torna ad inizio pagina
Danix
ven 28 ago 2009 - 15:00

online

Utente registrato #1
Registrato il: ven 29 dic 2006 - 05:38
Provenienza: Sassari
Messaggi: 12823
[Initial release] -Link-
Torna ad inizio pagina
Sito Web

Vai a pagina   <<        >>  
Moderatori: Danix, Taf, Rcs, Energy, zandet2, ZioZione, Admin, LordJim60

Salta:     Torna ad inizio pagina

RSS discussione: rss 0.92 RSS discussione: rss 2.0 RSS discussione: RDF
Powered by e107 Forum System