Main menu

Search
Login
Signup
Links
<< Previous thread | Next thread >>   
[Initial release] X-Iron_4.0.280.0_rev3

Go to page   <<        >>  
Author Post
Danix
Mon 17 Aug 2009 - 02:42

online

Registered Member #1
Joined: Fri 29 Dec 2006 - 05:38
Location: Sassari
Posts: 12914
UncleDan wrote ...

Ora devo solo capire come aggiungere a Preferences:
   "browser": {
      "check_default_browser": false
   },

per evitare la noiosissima domanda se lo vuoi come browser predefinito quando si crea il profilo.

Buona idea, non ci avevo pensato.
Prendi spunto dal nuovo x-default_prefs di Chromium -Link-

E aggiungi:

<<RE>>|0=("check_default_browser": ).+<<RE>>$1false

Sotto:

[StringRegExpReplace=%Profile%\Default\Preferences]

Back to top
Website
UncleDan
Mon 17 Aug 2009 - 09:54

online
Registered Member #4764
Joined: Sat 19 May 2007 - 19:39
Location: Bologna, Italy
Posts: 125
Ci avevo già pensato, ma non funziona in quanto il parametro non esiste finché non rispondi alla domanda, quindi il replace non trova nulla da sostituire. D'altro canto se usi un WriteToPref ed è già stato settato te lo trovi doppio (è solo una congettura, non sono riuscito a farglielo scrivere). Comunque ora sono abbastanza soddisfatto del risultato.

EDIT: vedo ora che l'hai applicato a Chromium, ora provo il tuo

[ Edited Mon 17 Aug 2009 - 10:01 ]
Back to top
Website
UncleDan
Mon 17 Aug 2009 - 12:23

online
Registered Member #4764
Joined: Sat 19 May 2007 - 19:39
Location: Bologna, Italy
Posts: 125
Nuova versione: -Link-

Come puoi vedere ho cambiato la revision, perché anche se è "fortemente ispirato" a X-Chromium.ini, per X-Iron.ini in definitiva è una rev1.

Ho aggiunto la riga per il default browser e (anche se non mi spiego il perché) funziona perfettamente con il launcher di X-Chromium.

Ho anche fatto i compiti ricompilando il launcher con l'icona giusta, ma con il mio (di cui allego comunque sorgenti ed eseguibile al pacchetto) ricompilato dai sorgenti di X-Launcher l'ini non funzia, con il launcher di X-Chromium sì. Allora ci sono tre possibilità:

  • Io sono completamente fuso
  • Nel launcher di X-Chromium ci sono delle personalizzazioni che non avendo i sorgenti non vedo
  • Tutte e due le precedenti


Al di là delle battute grazie per la pazienza dimostrata.

[ Edited Mon 17 Aug 2009 - 13:38 ]
Back to top
Website
UncleDan
Tue 25 Aug 2009 - 18:23

online
Registered Member #4764
Joined: Sat 19 May 2007 - 19:39
Location: Bologna, Italy
Posts: 125
Non sto a postare una nuova versione per questo, ma penso che la sezione Environment sia meglio così:

[Environment]
Profile=$Home$\$AppName$\Profiles
Registry=$Home$\$AppName$\Registry
DownloadDir=$Download$


Praticamente ho aggiunto \Profiles a %PROFILE%

Sto ancora facendo delle prove, ma mi è capitato a volte che non mi riproponesse wPP come home (torna a posto se cancelli il profilo, ma non è il massimo...)

Se mi data i sorgenti di X-Chromium launcher sarei curioso di provare a ricompilarlo perché al momento con il launcher compilato da me non va, mentre funzia con X-Chromium.exe (rinominato in X-Iron.exe)

Thanks in advance.
Back to top
Website
Taf
Wed 26 Aug 2009 - 09:16

online

Registered Member #251
Joined: Mon 22 Jan 2007 - 10:12
Location: Buttrio (UD)
Posts: 3319
Ciao UncleDan,
intanto grazie per i test che stai svolgendo.
appena tornano in zona i "guru" (Danix, Zandet2, ZioZione) vedrai che ti accontenteranno con i sorgenti.. (io non li ho a disposizione in questo momento).

in questo periodo "post ferie" ci vuole un po' più di pazienza del solito

Comunque, sarebbe meglio indagare più approfonditamente del perché X-Iron perde la home di WPP e si ripristina se cancelli il profilo. Non è ammissibile un simile comportamento... (sei riuscito ad associare una data situazione a questo comportamento? (es. Spostamento del programma su altro PC, Utilizzo su Vista, Utilizzo su XP etc. etc). ?

Grazie in anticipo per ogni tuo eventuale feedback

[ Edited Wed 26 Aug 2009 - 09:17 ]
Back to top
Niconweb
Wed 26 Aug 2009 - 09:39

online
Registered Member #9306
Joined: Fri 29 Feb 2008 - 18:16
Posts: 11
Ciao a tutti,
vorrei dire che anche Chromium presenta il problema del non mantenimento della pagina iniziale da quando è stata fatta l'ultima revisione del file .ini. Ed oltre a ciò, non mantiene il pulsante della pagina iniziale e la barra dei preferiti ("Mostra sempre la barra dei preferiti").
A voi succede?
Grazie
Back to top
UncleDan
Wed 26 Aug 2009 - 10:16

online
Registered Member #4764
Joined: Sat 19 May 2007 - 19:39
Location: Bologna, Italy
Posts: 125
Credevo di averlo associato alla pulizia completa (cache+cookie+pass.salvate,ecc), ma il post di Niconweb pur riguardando Chromium mi ha fatto riflettere sul fatto che nell'ini è stata aggiunta la riga

<<RE>>|0=("check_default_browser": ).+<<RE>>$1false

(confesso, è stata una mia idea che poi Danix ha applicato a Chromium) perché al primo avvio non chiedesse se impostarlo come browser di default. Appena ho un attimo la quoto e vedo se é lì il problema: anche voi dovrete avere un po' di pazienza...

EDIT: lavoro su diversi PC ma tutti XP PRO SP3

[ Edited Wed 26 Aug 2009 - 10:18 ]
Back to top
Website
Danix
Fri 28 Aug 2009 - 13:07

online

Registered Member #1
Joined: Fri 29 Dec 2006 - 05:38
Location: Sassari
Posts: 12914
UncleDan wrote ...

Non sto a postare una nuova versione per questo, ma penso che la sezione Environment sia meglio così:

[Environment]
Profile=$Home$\$AppName$\Profiles
Registry=$Home$\$AppName$\Registry
DownloadDir=$Download$


Praticamente ho aggiunto \Profiles a %PROFILE%

Secondo me va meglio la struttura precedente dove la cartella "Registry" fa parte delle altre cartelle del profilo.

UncleDan wrote ...

Sto ancora facendo delle prove, ma mi è capitato a volte che non mi riproponesse wPP come home (torna a posto se cancelli il profilo, ma non è il massimo...)

Forse è il caso di NON preimpostare la home di winPenPack perchè in quel modo non è possibile impostare altre pagine con l'opzione "Apri le seguenti pagine".

================================
vedi X-Chromium 3.0.190.0 [rev7] -Link-
================================

UncleDan wrote ...

Se mi data i sorgenti di X-Chromium launcher sarei curioso di provare a ricompilarlo perché al momento con il launcher compilato da me non va, mentre funzia con X-Chromium.exe (rinominato in X-Iron.exe)

Tutto il codice di winPenPack è su Subversion -Link-

Niconweb wrote ...

Ciao a tutti,
vorrei dire che anche Chromium presenta il problema del non mantenimento della pagina iniziale da quando è stata fatta l'ultima revisione del file .ini.

Il problema del non mantenimento di una pagina iniziale diversa da quella di winPenPack?


Niconweb wrote ...

Ed oltre a ciò, non mantiene il pulsante della pagina iniziale e la barra dei preferiti ("Mostra sempre la barra dei preferiti").

Il pulsante della pagina iniziale non lo trovo.


[ Edited Fri 28 Aug 2009 - 13:37 ]
Back to top
Website
Niconweb
Fri 28 Aug 2009 - 14:23

online
Registered Member #9306
Joined: Fri 29 Feb 2008 - 18:16
Posts: 11
Il pulsante della pagina iniziale non è impostato di default, occorre andare in opzioni --> impostazioni di base e spuntare "Mostra pulsante pagina iniziale nella barra degli strumenti"
Back to top
Danix
Fri 28 Aug 2009 - 15:00

online

Registered Member #1
Joined: Fri 29 Dec 2006 - 05:38
Location: Sassari
Posts: 12914
[Initial release] -Link-
Back to top
Website

Go to page   <<        >>  
Moderators: Danix, Taf, Rcs, Energy, zandet2, ZioZione, Admin, LordJim60

Jump:     Back to top

Syndicate this thread: rss 0.92 Syndicate this thread: rss 2.0 Syndicate this thread: RDF
Powered by e107 Forum System