Menù Principale

Cerca
Login
Registrati
Link
<< Discussione precedente | Discussione successiva >>   
[Released] X-LibreOffice 3.5.0_rev9

Vai a pagina   <<        >>  
Autore Messaggio
barta
lun 13 feb 2012 - 19:31

online
Utente registrato #4207
Registrato il: mar 17 apr 2007 - 16:50
Messaggi: 291
qui il mistero si infittisce...

X-LibO 3.5.0 copiato su chiavetta e funzionante su Vista 64 e sul portatile Asus XP 32 di mia moglie,
non ne vuole sapere di girare sui 2 PC Acer XP 32 di cui parlavo prima e non funziona nemmeno su
un terzo PC HP con XP 32 bit.

il messaggio di errore è leggermente diverso:

LibreOffice 3.5 - Fatal Error
an error occurred during file opening.

mi viene un dubbio. siccome i 3 PC con XP in cui ho i problemi non sono aggiornatissimi,
non è che esistono particolari aggiornamenti di Windows Update, necessari a far girare i
programmi wPP?

per la cronaca i primi 2 PC sono XP service pack 2, mentre il terzo è SP3
Torna ad inizio pagina
Taf
lun 13 feb 2012 - 19:54

online

Utente registrato #251
Registrato il: lun 22 gen 2007 - 10:12
Provenienza: Buttrio (UD)
Messaggi: 3306
Mah, io oggi ho provato l'ultima versione anche su un netbook che ho a casa (con XP SP2) e non ho avuto nessun problema.

01) Non che ci sono di mezzo dei privilegi di amministratore? (non vorrei mai che questa ultima versione fosse diventata più delicata con macchine "bloccate").
02) hai provato da chiavetta USB oppure hai copiato su Disco fisso?
03) se era su HD, era posizionato su cartelle che il S.O. reputa di sistema?
04) Java è installato sui PC oppure il programma sfrutta la versione portabile (che si scarica alla prima esecuzione, se assente nel pacchetto)?
05) la 3.4.5 funziona su tutti i PC?

aspettiamo news....

[ Modificato lun 13 feb 2012 - 20:24 ]
Torna ad inizio pagina
barta
lun 13 feb 2012 - 22:11

online
Utente registrato #4207
Registrato il: mar 17 apr 2007 - 16:50
Messaggi: 291
Taf ha scritto ...

Mah, io oggi ho provato l'ultima versione anche su un netbook che ho a casa (con XP SP2) e non ho avuto nessun problema.

01) Non che ci sono di mezzo dei privilegi di amministratore? (non vorrei mai che questa ultima versione fosse diventata più delicata con macchine "bloccate").


che io sappia no. A tutti e 3 i PC si accede tramite password iniziale (che tra l'altro in 2 di questi non è altro che il tasto “Enter”) ma poi non c'è alcun blocco all'installazione di programmi

ha scritto ...

02) hai provato da chiavetta USB oppure hai copiato su Disco fisso?


entrambe le cose... non funziona in nessuno dei casi.

ha scritto ...

03) se era su HD, era posizionato su cartelle che il S.O. reputa di sistema?


su hard disk erano state messe sotto C:/Programmi oppure sotto C:/ e basta.
Tutte location che ho sempre usato senza problemi con le vecchie X-versioni

ha scritto ...

04) Java è installato sui PC oppure il programma sfrutta la versione portabile (che si scarica alla prima esecuzione, se assente nel pacchetto)?


se non erro java era già presente su entrambi i PC, e comunque si trattava di X-LibO che avevano già effettuato lo scarico ed installazione del java interno

ha scritto ...

05) la 3.4.5 funziona su tutti i PC?


alla grande. Sempre funzionato benissimo sia su Vista che su XP

Torna ad inizio pagina
barta
lun 13 feb 2012 - 22:30

online
Utente registrato #4207
Registrato il: mar 17 apr 2007 - 16:50
Messaggi: 291
nel frattempo ho chiesto sul newsgroup di OOo/LibO se per favore qualcun altro faceva dei test.

come detto io ho un 3/4 di fallimento su XP.

non penso possa essere un caso... qualche magagna sotto ci deve essere
Torna ad inizio pagina
Taf
mar 14 feb 2012 - 17:11

online

Utente registrato #251
Registrato il: lun 22 gen 2007 - 10:12
Provenienza: Buttrio (UD)
Messaggi: 3306
Per Danix e Team:
ecco la risposta di VITRIOL sul NG di OOO/LIBO
Il 13/02/2012 22:14, Tommy ha scritto:


se avete XP mi provate a vedere su X-LibO 3.5.0 scaricabile da qui:
-Link-
funziona oppure no?

Provato su sistema XP HE 32 bit SP3 da chiavetta, e l'applicazione di avvia correttamente.
L'errore che hai riportato mi sembra possa essere relativo a qualche libreria DLL (esempio Visual C++) mancante o non aggiornata. Da notare che nella versione installabile le librerie Visual C++ vengono distribuite e installate con il pacchetto.
A titolo di prova consiglio di cercare su Windows Update e aggiornare all'ultima versione le librerie "Microsoft Visual C++ Redistributable".
--
Saluti
VITRIOL


1) pensi/ate sia plausibile quanto riportato da Vitriol?
2) se si, secondo voi, si potrebbe fare una verifica della presenza delle DLL in fase di prima installazione della suite sotto XP?


---- E D I T ------
ulteriore suggerimento del buon Vitriol:

LibO distribuisce l'help locale italiano (e per tutte le lingue, a dire il vero) come file di istallazione separato sotto il nome di LibO_3.x.x_Win_x86_helppack_xx.exe/msi. Se non si installa in locale questo file l'help punta alla versione web, aprendo il browser predefinito e visualizzando la versione online.
Credo che la versione portatile, che dovrebbe essere il più indipendente possibile, dovrebbe includere l'help locale, visualizzato in maniera tradizionale senza l'accesso a internet.
--
Saluti
VITRIOL


[ Modificato mar 14 feb 2012 - 17:50 ]
Torna ad inizio pagina
Danix
mar 14 feb 2012 - 20:18

online

Utente registrato #1
Registrato il: ven 29 dic 2006 - 05:38
Provenienza: Sassari
Messaggi: 12908
Per quanto riguarda le dll, avevo pensato anch'io che potessero essere una possibile causa del problema di barta.
Nella nostra distribuzione vengono copiate da $Lib$ le dll di versione diversa rispetto a quelle distribuite con la 3.5.0.
barta, decomprimi il setup con UniExtract, copia le dll che trovi in \Cartella estrattaWindows\system32 e sovrascrivile a quelle presenti in LibreOffice 3\URE\bin e LibreOffice 3\program. Verifica quindi che nei due pc con XP non ri ripresenti l'errore.

Sugli Help Pack sono d'accordo, ma esiste un pacchetto che li racchiuda tutti? Anche perchè installare 107 Help Pack ogni volta non è che sia un giochetto..


[ Modificato mar 14 feb 2012 - 20:18 ]
Torna ad inizio pagina
Sito Web
barta
mar 14 feb 2012 - 21:22

online
Utente registrato #4207
Registrato il: mar 17 apr 2007 - 16:50
Messaggi: 291
Danix ha scritto ...

Per quanto riguarda le dll, avevo pensato anch'io che potessero essere una possibile causa del problema di barta.
Nella nostra distribuzione vengono copiate da $Lib$ le dll di versione diversa rispetto a quelle distribuite con la 3.5.0.


non ho capito bene... mi stai dicendo che dentro a X-LibO non ci sono le .dll della versione originale 3.5.0 bensì
.dll copiate dal sistema ospite? questa $Lib$ dove si trova? nel mio PC o dentro il pacchetto originale LibO o nel vostro assemblaggio X-LibO?

Danix ha scritto ...

barta, decomprimi il setup con UniExtract, copia le dll che trovi in \Cartella estrattaWindows\system32 e sovrascrivile a quelle presenti in LibreOffice 3\URE\bin e LibreOffice 3\program. Verifica quindi che nei due pc con XP non si ripresenti l'errore.


adesso mi sto proprio scaricando il file .msi originale di LibO. domani faccio la prova.
ma le .dll le devo copiare e sovrascrivere proprio tutte o solo alcune?


Torna ad inizio pagina
ZioZione
mar 14 feb 2012 - 22:59
online

Utente registrato #74
Registrato il: dom 21 gen 2007 - 11:31
Provenienza: Tradate (VA)
Messaggi: 3821
Ciao Danix,
Danix ha scritto ...

Sugli Help Pack sono d'accordo, ma esiste un pacchetto che li racchiuda tutti? Anche perchè installare 107 Help Pack ogni volta non è che sia un giochetto..


questo -Link- è il meglio che sono riuscito a trovare finora... ma serve comunque scaricarli uno alla volta (a meno che non si pensi di mettere in piedi un sistema "Mozilla Builder style" ). Ci penso su...
Cordialmente
ZioZione
Torna ad inizio pagina
barta
mer 15 feb 2012 - 07:33

online
Utente registrato #4207
Registrato il: mar 17 apr 2007 - 16:50
Messaggi: 291
Danix ha scritto ...


Sugli Help Pack sono d'accordo, ma esiste un pacchetto che li racchiuda tutti? Anche perchè installare 107 Help Pack ogni volta non è che sia un giochetto..



107 help pack sono davvero troppi.
magari ci si può limitare a italiano, inglese, tedesco, francese e spagnolo.
con buona pace degli utenti tailandesi, uzbeki e cingalesi...
Torna ad inizio pagina
barta
mer 15 feb 2012 - 09:24

online
Utente registrato #4207
Registrato il: mar 17 apr 2007 - 16:50
Messaggi: 291
Allora direi che il problema è proprio quello delle .dll come suggerito da VITRIOL sul newsgroup di OOo/LibO

Ho installato LibO 3.5 ufficiale su uno dei PC con XP ribelli.
Con lui presente, X-LibO da chiavetta funziona tranquillamente.
Non appena disinstallo LibO ufficiale, X-LibO torna a non funzionare a causa del fatal error descritto prima.

Quindi a quanto pare X-LibO 3.5.0 per funzionare deve trovare nel PC ospite delle .dll aggiornate, che se mancanti ne pregiudicano il funzionamento...

evidentemente X-LibO 3.4.x era più di bocca buona e si accontentava anche di .dll non aggiornate mentre X-LibO 3.5 vuole solo quelle nuove.
purtroppo le .dll necessarie vengono perse con la disinstallazione di LibO ufficiale.

Mi chiedo a questo punto se siete in grado di fare una rev9 di X-LibO che si porti in dote le .dll necessarie, e non se le va da a cercare nel sistema...

considerate infatti che non tutti hanno PC aggiornati o connessi ad internet e che il workaround di tenere una versione 3.5.0 ufficiale installata è antitetico alla filosofia portable no-install di WPP

probabilmente SO più recenti (non ho avuto alcun problema con Vista e Win7) non hanno questo problema, ma di vecchi XP in giro ce ne sono ancora parecchi.
Torna ad inizio pagina

Vai a pagina   <<        >>  
Moderatori: Danix, Taf, Rcs, Energy, zandet2, ZioZione, Admin, LordJim60

Salta:     Torna ad inizio pagina

RSS discussione: rss 0.92 RSS discussione: rss 2.0 RSS discussione: RDF
Powered by e107 Forum System