Menù Principale

Cerca
Login
Registrati
Link
<< Discussione precedente | Discussione successiva >>   
X-LibreOffice 4.0.0 [rev14] - Errore all'apertura

Vai a pagina   <<        >>  
Autore Messaggio
dito
mer 24 apr 2013 - 20:15

online
Utente registrato #11533
Registrato il: sab 31 mag 2008 - 09:32
Messaggi: 196
Questi sono i percosi:
C:\.........\X-LibreOffice\Lib\Java\bin\msvcr100.dll
C:\.........\X-LibreOffice\Lib\Java\bin\plugin2\msvcr100.dll
C:\.........\X-LibreOffice\Bin\LibreOffice 4\program\msvcr80.dll



[ Modificato mer 24 apr 2013 - 20:23 ]
Torna ad inizio pagina
barta
mer 24 apr 2013 - 20:26

online
Utente registrato #4207
Registrato il: mar 17 apr 2007 - 16:50
Messaggi: 291
dito ha scritto ...

Questi sono i percosi:
C:\.........\X-LibreOffice\Lib\Java\bin\msvcr100.dll
C:\.........\X-LibreOffice\Lib\Java\bin\plugin2\msvcr100.dll
C:\.........\X-LibreOffice\Bin\LibreOffice 4\program\msvcr80.dll




quindi se non ho capito male, la msvcr100.dll incriminata non va messa in "program" (dove ci sta la msvcr80.dll) bensì nei 2 percorsi Lib/Java/bin ecc ecc. che hai segnato...
giusto?

[ Modificato mer 24 apr 2013 - 20:27 ]
Torna ad inizio pagina
dito
mer 24 apr 2013 - 21:05

online
Utente registrato #11533
Registrato il: sab 31 mag 2008 - 09:32
Messaggi: 196
@Barta
A dire il vero, a suo tempo, su suggerimento di Danix (vedi alcuni post sopra), avevo inserito MSVCR100-dll in program, ma ora la ritrovo nelle posizioni che ho riportato più sopra.
Torna ad inizio pagina
dito
gio 25 apr 2013 - 06:04

online
Utente registrato #11533
Registrato il: sab 31 mag 2008 - 09:32
Messaggi: 196
Ma in un'altro pc (sempre Win7 64bit) che è quello su cui in effetti ho seguito i suggerimenti di Danix ( -Link- ), i percorsi sono questi:

D:\......\X-LibreOffice 4\Bin\LibreOffice 4\program\msvcr100.dll
D:\......\X-LibreOffice 4\Lib\Java\bin\msvcr100.dll
D:\......\X-LibreOffice 4\Lib\Java\bin\plugin2\msvcr100.dll
D:\......\X-LibreOffice 4\Bin\LibreOffice 4\program\msvcr80.dll

Quest'ultimo è probabilmente più attendibile.

Nel pc precedente X-LibO utilizzava inizialmente Java installato in C che poi ho disinstallato.
Al riavvio di X-LibO si è scaricato il pacchetto Java portable.
Forse la differenza dipende da questo.

[ Modificato gio 25 apr 2013 - 10:16 ]
Torna ad inizio pagina
barta
gio 25 apr 2013 - 10:07

online
Utente registrato #4207
Registrato il: mar 17 apr 2007 - 16:50
Messaggi: 291
ok. proverò a mettere la msvcr100.dll anche in "program" ed in "java/bin ecc. ecc."

purtroppo non ho sotto mano il PC Win7 su cui fare il test.

faccio sapere non appena ho risolto.
Torna ad inizio pagina
barta
gio 25 apr 2013 - 21:15

online
Utente registrato #4207
Registrato il: mar 17 apr 2007 - 16:50
Messaggi: 291
dito ha scritto ...

Ma in un'altro pc (sempre Win7 64bit) che è quello su cui in effetti ho seguito i suggerimenti di Danix ( -Link- ), i percorsi sono questi:

D:\......\X-LibreOffice 4\Bin\LibreOffice 4\program\msvcr100.dll


questa in effetti in X-LibO non c'è

dito ha scritto ...

D:\......\X-LibreOffice 4\Lib\Java\bin\msvcr100.dll
D:\......\X-LibreOffice 4\Lib\Java\bin\plugin2\msvcr100.dll
D:\......\X-LibreOffice 4\Bin\LibreOffice 4\program\msvcr80.dll


questi 3 files invece ci sono già

quindi la "msvcr100.dll" già viene distribuita in X-LibO ma per qualche motivo non è presente in "program" mentre lo è nelle subfolders "Java"
Torna ad inizio pagina
barta
ven 26 apr 2013 - 14:52

online
Utente registrato #4207
Registrato il: mar 17 apr 2007 - 16:50
Messaggi: 291
ce l'ho fatta!!!

per far girare X-LibO 4.0.2 sul mio PC Win7 Ultimate 64bit è stato necessario copiare 2 files .dll nella directory:

D:\......\X-LibreOffice 4\Bin\LibreOffice 4\program\

il primo file è "msvcr100.dll" che come detto è già presente nel pacchetto X-LibO sotto "D:\......\X-LibreOffice 4\Lib\Java\bin\"

poi serve un altro file che si chiama "msvcp100.dll" che io ho trovato su un alto PC delle dimensioni di 411KB

anche questo va messo in "program"

con entrambi i files X-LibO gira.

solo con "msvcr100.dll" invece mi dava messaggio di errore chiedendomi "msvcp100.dll"

come detto nella Rev15 sarebbe bene ci fossero entrambi




Torna ad inizio pagina
Danix
ven 26 apr 2013 - 16:03

online

Utente registrato #1
Registrato il: ven 29 dic 2006 - 05:38
Provenienza: Sassari
Messaggi: 12898
msvcp100.dll e msvcr100.dll vengono forniti con LibreOffice.
Confermi che se inseriti in \Bin\LibreOffice 4\program\ LibreOffice si avvia?
Torna ad inizio pagina
Sito Web
barta
ven 26 apr 2013 - 17:23

online
Utente registrato #4207
Registrato il: mar 17 apr 2007 - 16:50
Messaggi: 291
Danix ha scritto ...

msvcp100.dll e msvcr100.dll vengono forniti con LibreOffice.
Confermi che se inseriti in \Bin\LibreOffice 4\program\ LibreOffice si avvia?


è esattamente quello che ho scritto nel post precedente.
servono entrambi e devono stare dentro a "...\Bin\LibreOffice 4\program\

le dimensioni dei files sono:
- 752KB per "msvcr100.dll"
- 411KB per "msvcp100.dll"
Torna ad inizio pagina
dito
sab 27 apr 2013 - 07:49

online
Utente registrato #11533
Registrato il: sab 31 mag 2008 - 09:32
Messaggi: 196
barta ha scritto ...

Danix ha scritto ...

msvcp100.dll e msvcr100.dll vengono forniti con LibreOffice.
Confermi che se inseriti in \Bin\LibreOffice 4\program\ LibreOffice si avvia?


è esattamente quello che ho scritto nel post precedente.
servono entrambi e devono stare dentro a "...\Bin\LibreOffice 4\program\

le dimensioni dei files sono:
- 752KB per "msvcr100.dll"
- 411KB per "msvcp100.dll"


Confermo anche io: i due file devono essere inseriti in ...\Bin\LibreOffice 4\program\ altrimenti X-LibO non si avvia.
Torna ad inizio pagina

Vai a pagina   <<        >>  
Moderatori: Danix, Taf, Rcs, Energy, zandet2, ZioZione, Admin, LordJim60

Salta:     Torna ad inizio pagina

RSS discussione: rss 0.92 RSS discussione: rss 2.0 RSS discussione: RDF
Powered by e107 Forum System