Menù Principale

Cerca
Login
Registrati
Link
<< Discussione precedente | Discussione successiva >>   
X-LibreOffice 7.5.3 - Errore aggiornamento Java 8.0 Build 371

Autore Messaggio
rbon
mar 23 mag 2023 - 18:59
online
Utente registrato #4134
Registrato il: sab 14 apr 2007 - 11:42
Messaggi: 915

Dunque,
ho preso la versione di X-LibreOffice 7.5.1 per win64 (da Sourceforge.net) ed ho:
1. aggiornato gli eseguibili alla versione 7.5.3
2. modificato il launcher (impostato come primo avvio!) in modo che esegua il download di Java 8.0 build 371.
3. avviata un'installazione pulita di X-LibreOffice 7.5.3.

Tuttavia lanciando X-LibreOffice ho visto che Java non viene riconosciuto: ho risolto navigando nella cartella corretta e confermando.
Tutto bene? No.

Ho ottenuto un file 'javamove.txt' con questo contenuto:
ha scritto ...

-------------------------------------------------------------------------------
ROBOCOPY :: Copia di file efficace per Windows
-------------------------------------------------------------------------------

Avviato: Wed Apr 19 18:10:55 2023

Origine : C:\PortableApps\X-LibreOffice\Lib\Java\jre1.8.0_361\
Destinazione : C:\PortableApps\X-LibreOffice\Lib\Java\

File: *.*

Opzioni: *.* /S /E /COPY:DAT /MOVE /R:1000000 /W:30

-------------------------------------------------------------------------------
2023/04/19 18:10:55 ERRORE 2 (0x00000002) Accesso alla directory di origine in corso C:\PortableApps\X-LibreOffice\Lib\Java\jre1.8.0_361\
Impossibile trovare il file specificato.

penso che Java 8.0.371 debba essere aggiornato sul sito winPenPack.
Non è un grosso problema, ma bisogna essere un pochino 'smanettoni'.
Forse Danix saprà la risposta corretta.



Torna ad inizio pagina
Danix
mar 23 mag 2023 - 22:37

online

Utente registrato #1
Registrato il: ven 29 dic 2006 - 05:38
Provenienza: Sassari
Messaggi: 12956
rbon ha scritto ...


2. modificato il launcher (impostato come primo avvio!) in modo che esegua il download di Java 8.0 build 371.


Il launcher al momento scarica "jre1.8.0_361".
Hai inserito un nuovo link nel file X-LibreOffice.ini?

JavaUDir="jre1.8.0_361"
JavaURL="https://javadl.oracle.com/webapps/download/AutoDL?BundleId=247946_0ae14417abb444ebb02b9815e2103550"



[ Modificato mar 23 mag 2023 - 22:37 ]
Torna ad inizio pagina
Sito Web
rbon
mer 24 mag 2023 - 17:47
online
Utente registrato #4134
Registrato il: sab 14 apr 2007 - 11:42
Messaggi: 915
Danix ha scritto ...

rbon ha scritto ...


2. modificato il launcher (impostato come primo avvio!) in modo che esegua il download di Java 8.0 build 371.


Il launcher al momento scarica "jre1.8.0_361".
Hai inserito un nuovo link nel file X-LibreOffice.ini?

JavaUDir="jre1.8.0_361"
JavaURL="https://javadl.oracle.com/webapps/download/AutoDL?BundleId=247946_0ae14417abb444ebb02b9815e2103550"



Si, ho inserito un nuovo link nel file x-LibreOffice.ini
questo è il frammento del file .ini modificato:

---------------------------
[Setup]
AppName=LibreOffice 7
AppVer=7.5.3
JavaUDir="jre1.8.0_371"
JavaURL="https://javadl.oracle.com/webapps/download/AutoDL?BundleId=248243_ce59cff5c23f4e2eaf4e778a117d4c5b"
---------------------------

come si vede il link di download (JavaURL) è stato modificato con l'ultima versione

Il launcher modificato scarica regolarmente la nuova versione di Java 8.0.371, solo che:
1. crea il file 'javamove.txt' con l'errore
2. bisogna avviare X-LibreOffice --> Strumenti --> Opzioni --> Avanzate, selezionare manualmente la cartella contenente jre1.8.0_371 e confermare.

Torna ad inizio pagina
Danix
gio 25 mag 2023 - 10:12

online

Utente registrato #1
Registrato il: ven 29 dic 2006 - 05:38
Provenienza: Sassari
Messaggi: 12956
Quindi non è un problema di download/installazione della nuova versione di Java, ma (solo) di riconoscimento di Java da parte del programma una volta conclusa l'operazione..

I due link per la nuova versione quali sono?
Uno è (presumo 64bit):
https://javadl.oracle.com/webapps/download/AutoDL?BundleId=248243_ce59cff5c23f4e2eaf4e778a117d4c5b

L'altro?

[ Modificato gio 25 mag 2023 - 10:12 ]
Torna ad inizio pagina
Sito Web
rbon
gio 25 mag 2023 - 19:04
online
Utente registrato #4134
Registrato il: sab 14 apr 2007 - 11:42
Messaggi: 915
Danix ha scritto ...

Quindi non è un problema di download/installazione della nuova versione di Java, ma (solo) di riconoscimento di Java da parte del programma una volta conclusa l'operazione..

I due link per la nuova versione quali sono?

Uno è per JRE 8.0.371 a 64bit:
https://javadl.oracle.com/webapps/download/AutoDL?BundleId=248243_ce59cff5c23f4e2eaf4e778a117d4c5b

L'altro?

l'altro link per JRE 8.0.371 a 32 bit è:
https://javadl.oracle.com/webapps/download/AutoDL?BundleId=248241_ce59cff5c23f4e2eaf4e778a117d4c5b

Torna ad inizio pagina
Danix
sab 27 mag 2023 - 11:03

online

Utente registrato #1
Registrato il: ven 29 dic 2006 - 05:38
Provenienza: Sassari
Messaggi: 12956
Michele_Pezza, ho verificato. Sembra che JavaUDir="jre1.8.0_371" non venga letta nell'INI.

Forse dipende dal fatto che nel sorgente (x-udf.au3) c'è la seguente stringa?

Local $sSource = ".\jre1.8.0_361"



--- edit ---

Effettivamente tutto funziona ricompilando il launcher con

Local $sSource = ".\jre1.8.0_371"


In allegato il nuovo launcher. Provalo rbon.

x-libreoffice_7.5.3_win64_rev22.zip


@Michele_Pezza,
Si può intervenire modificando l'INI ad ogni nuova versione di Java, senza modificare i sorgenti e ricompilare ogni volta il launcher?




[ Modificato sab 27 mag 2023 - 11:27 ]
Torna ad inizio pagina
Sito Web
rbon
sab 27 mag 2023 - 18:45
online
Utente registrato #4134
Registrato il: sab 14 apr 2007 - 11:42
Messaggi: 915
Danix ha scritto ...

In allegato il nuovo launcher. Provalo rbon.

x-libreoffice_7.5.3_win64_rev22.zip


Ho sostituito il vecchio launcher con quello nuovo che hai allegato.

Funziona regolarmente.
Tuttavia non ho eseguito una nuova installazione avendo già installato X-LibreOffice 7.5.3 a 64 bit.

Rimane una curiosità:
--> il tuo nuovo launcher ha una dimensione di KB 1.028: hai utilizzato AutoIt 3.2.12.1 e non hai compilato per 64 bit;
--> il launcher di Michele_Pezza ha una dimensione di KB 1.147: era stato creato con AutoIt 3.3.16.0 e compilato per 64 bit.
Confermi ciò?



Torna ad inizio pagina
Danix
sab 27 mag 2023 - 19:39

online

Utente registrato #1
Registrato il: ven 29 dic 2006 - 05:38
Provenienza: Sassari
Messaggi: 12956
rbon ha scritto ...

hai utilizzato AutoIt 3.2.12.1 e non hai compilato per 64 bit;
--> il launcher di Michele_Pezza ha una dimensione di KB 1.147: era stato creato con AutoIt 3.3.16.0 e compilato per 64 bit.
Confermi ciò?

Non confermo, ho compilato con AutoIt 3.3.16.1, da cosa deduci che ho usato la versione 3.2.12.1?
Torna ad inizio pagina
Sito Web
rbon
sab 27 mag 2023 - 19:51
online
Utente registrato #4134
Registrato il: sab 14 apr 2007 - 11:42
Messaggi: 915
Danix ha scritto ...

Non confermo, ho compilato con AutoIt 3.3.16.1, da cosa deduci che ho usato la versione 3.2.12.1?

Mi sembrava di avere visto sulle proprietà del launcher, ma posso essermi sbagliato.
Ciao.
Torna ad inizio pagina

Moderatori: Danix, Taf, Rcs, Energy, zandet2, ZioZione, Admin, LordJim60

Salta:     Torna ad inizio pagina

RSS discussione: rss 0.92 RSS discussione: rss 2.0 RSS discussione: RDF
Powered by e107 Forum System